Anzeige

Excel: wenn dann Funktion zusammenfassen

Excel: wenn dann Funktion zusammenfassen | PSD-Tutorials.de

Erstellt von Ilse_Schnick, 06.07.2015.

  1. Ilse_Schnick

    Ilse_Schnick Aktives Mitglied

    Dabei seit:
    23.09.2005
    Beiträge:
    435
    Geschlecht:
    weiblich
    Ort:
    Bärlin
    Excel: wenn dann Funktion zusammenfassen
    Liebe Leute oder vielleicht besser: Lieber ExcelNerd

    Ich habe eine Frage:

    Ausgangslage:

    Blatt 1 = Tabelle1
    Code (Text):
    1.  
    2.  
    3. lfdt Nummer | Inhalt 1
    4. 1                    a
    5. 2                    b
    6. 3                    c
    7. ...                  ...
    8.  
    Blatt 2 Tabelle 2

    Hier gibt es nur eine Zeile (dient später zur Einzelabrechnung):

    Wenn in Spalte 1 die lft. Nr. 1 eingegeben wird, soll in Spalte 2 automatisch der Wert aus Tabelle1!Inhalt 1 übernommen werden
    wenn 2 dann Inhalt 2 usw. ... wenn 100 dann Inhalt 100

    Ich bin nicht so fit, was Excel angeht, darum meine Frage:

    Wie kann ich die "Wenn - dann" zusammenfassen?

    Bis dato fällt mir nur ein:

    Code (Text):
    1.  
    2. =WENN(A1=1;Tabelle1!B1;WENN(A1=2;Tabelle1!B2;WENN(A1=3;Tabelle1!B3)))
    3.  

    Ist bei 3 Zeilen noch kein Ding, wenn es aber 100 oder 200 werden, dann wird es schon 'ne elendige Tipperei... und ich weiß im Vorfeld auch nicht, wie viele laufende Nummern es geben wird...

    Irgendwie steh ich da auf dem Schlauch...
     
    #1      
  2. nedserdpsd

    nedserdpsd Nicht mehr ganz neu hier

    Dabei seit:
    27.03.2009
    Beiträge:
    106
    Geschlecht:
    männlich
    Software:
    PS CC, LR CC
    Kameratyp:
    Canon 6D
    Excel: wenn dann Funktion zusammenfassen
    Wenn die Werte in Tabelle1 in Zeile 2 losgehen, könntest du in Tabelle2 z.B. so etwas nehmen
    =INDIREKT("tabelle1!B"&A2+1)
     
    #2      
  3. Ilse_Schnick

    Ilse_Schnick Aktives Mitglied

    Dabei seit:
    23.09.2005
    Beiträge:
    435
    Geschlecht:
    weiblich
    Ort:
    Bärlin
    Excel: wenn dann Funktion zusammenfassen
    Merci erst mal, aber das löst mein Problem irgendwie nicht...

    wenn jemand in Tabelle 2 einen Wert (laufende Nummer = ganze Zahlen) in spalte 1 eingibt, soll eben in Spalte 2 der entsprechende wert (Text) aus Tabelle 1 passend zur Zeile angezeigt werden?
     
    #3      
  4. nedserdpsd

    nedserdpsd Nicht mehr ganz neu hier

    Dabei seit:
    27.03.2009
    Beiträge:
    106
    Geschlecht:
    männlich
    Software:
    PS CC, LR CC
    Kameratyp:
    Canon 6D
    Excel: wenn dann Funktion zusammenfassen
    Wenn in Tabelle2 in Spalte a2 die lfd.Nr eingetragen wird und die Formel z.B. in Spalte b2 steht, dann sollte genau das passieren, allerdings mit der genannten Voraussetzung, dass die lfdNr ab Zeile 2 losgehen. Wenn das - wie in deinem obigen Beispiel - erst ab Zeile 4 losgeht, dann müsste statt +1 eben +3 stehen.

    Falls es immer noch nicht klappen sollte, könntest du vielleicht mal sagen, was für ein Ergebnis erscheint.
     
    #4      
    Ilse_Schnick gefällt das.
  5. kidding82

    kidding82 Aktives Mitglied

    Dabei seit:
    01.09.2009
    Beiträge:
    1.631
    Geschlecht:
    männlich
    Ort:
    nähe Linz/Rhein
    Software:
    Win10, LR5, PSE10(+), PSE11, Nik-Collection, DPP, Div Freeware
    Kameratyp:
    Canon EOS 60D; Tamron 28-75mm f2,8 & Tamron 55-200mm f4,5-5,6 ;Canon 18-55mm KIT
    Excel: wenn dann Funktion zusammenfassen
    Probiere es mal mit "SVerweis". Hier gibt man einen Datenbereich Gesucht:Ergebnis an, und ein Suchfeld. Steht in dem Suchfeld ein Eintrag aus dem Datenbereich Gesucht, dann wird der dazugehörige Zeileneintrag Ergebnis dazu ausgegeben. Bin gerade am kochen, aber gebe gleich noch ein Beispiel bzw Hilfe dazu wenn ich wieder Zeit hab

    EDIT
    http://www.excel-helfer.de/excel-matrixformel-die-funktion-sverweis-bzw-wverweis.html
     
    #5      
    Ilse_Schnick gefällt das.
  6. Ilse_Schnick

    Ilse_Schnick Aktives Mitglied

    Dabei seit:
    23.09.2005
    Beiträge:
    435
    Geschlecht:
    weiblich
    Ort:
    Bärlin
    Excel: wenn dann Funktion zusammenfassen
    'n Gutn :)
     
    #6      
  7. Ilse_Schnick

    Ilse_Schnick Aktives Mitglied

    Dabei seit:
    23.09.2005
    Beiträge:
    435
    Geschlecht:
    weiblich
    Ort:
    Bärlin
    Excel: wenn dann Funktion zusammenfassen
    Code (Text):
    1.  
    2. =SVERWEIS(A1;Tabelle1!A:A;Tabelle1!B:B;FALSCH)
    3.  
    Fehlermeldung Bezug ?
     
    #7      
  8. kidding82

    kidding82 Aktives Mitglied

    Dabei seit:
    01.09.2009
    Beiträge:
    1.631
    Geschlecht:
    männlich
    Ort:
    nähe Linz/Rhein
    Software:
    Win10, LR5, PSE10(+), PSE11, Nik-Collection, DPP, Div Freeware
    Kameratyp:
    Canon EOS 60D; Tamron 28-75mm f2,8 & Tamron 55-200mm f4,5-5,6 ;Canon 18-55mm KIT
    Excel: wenn dann Funktion zusammenfassen
    [​IMG]

    Code (Text):
    1. =SVERWEIS(A1;Tabelle1!A1:B2;2;0)
    wäre Dein Code zum anderen Arbeitsblatt, wenn in A1-A2 die Bezugsdaten stehen und in B1-B2 die anzuzeigenden Daten....
     
    #8      
    Ilse_Schnick gefällt das.
  9. Ilse_Schnick

    Ilse_Schnick Aktives Mitglied

    Dabei seit:
    23.09.2005
    Beiträge:
    435
    Geschlecht:
    weiblich
    Ort:
    Bärlin
    Excel: wenn dann Funktion zusammenfassen

    Ah ja Danke :) Ich habs jetzt erst mal...

    Merci, merci... :liebe:
     
    #9      
    kidding82 gefällt das.
  10. Hannu

    Hannu Nicht mehr ganz neu hier

    1
    Dabei seit:
    19.07.2005
    Beiträge:
    115
    Geschlecht:
    männlich
    Ort:
    CUX
    Software:
    Photoshop CS6, Indesign, Affinity Photo (iPad)
    Kameratyp:
    Sony Alpha 200
    Excel: wenn dann Funktion zusammenfassen
    Eine weitere Alternative
    =INDEX(Tabelle1!B:B;VERGLEICH(A1;Tabelle1!A:A;0))
    in Zelle B1 im Tabellenblatt2
     
    #10      
    Ilse_Schnick gefällt das.
  11. Ilse_Schnick

    Ilse_Schnick Aktives Mitglied

    Dabei seit:
    23.09.2005
    Beiträge:
    435
    Geschlecht:
    weiblich
    Ort:
    Bärlin
    Excel: wenn dann Funktion zusammenfassen
    Dankö... :*

    Ich muss aus Tabelle 1 mehrere Sachen übertragen, das mit sverweis funzt super...

    Nachtrag:
    Hab mich jetzt doch für deine Variante entschieden, dann kann ich die Zwischenspalten ignorieren :)

    Merci nochmal...
     
    Zuletzt bearbeitet: 07.07.2015
    #11      
  12. sacht

    sacht langjähriger Knipser

    Dabei seit:
    21.01.2011
    Beiträge:
    39
    Geschlecht:
    männlich
    Ort:
    Hamm/Westf.
    Software:
    PS4
    Kameratyp:
    DSLR Nikon
    Excel: wenn dann Funktion zusammenfassen
    Wie wär es mit dem guten alten SVerweis? Wenn die verwendeten Tabellen Mappe1 und Mappe2 und die Arbeitsblätter jeweils Tabelle1 heißen, geht es mit:
    =SVERWEIS(A1;[Mappe1]Tabelle1!$A$2:$B$4;2;0)
    Wenn du in der 2. Mappe nichts eingetragen hast ensteht natürlich ein Fehler. Dieser kann unterdrückt werden wenn man die Formel noch etwas erweitert, und zwar
    =WENN(ISTFEHLER(SVERWEIS(A1;[Mappe1]Tabelle1!$A$2:$B$4;2;0));"";SVERWEIS(A1;[Mappe1]Tabelle1!$A$2:$B$4;2;0))
    Diese Formel kannst du dann beliebig oft kopieren wodurch sich die Schreibarbeit in Grenzen hält.
    In meinem Excel 2013 funktioniert das.
     
    #12      
  13. essdreipro

    essdreipro Guest

    Excel: wenn dann Funktion zusammenfassen
    SVERWEIS ist schon ein guter Weg...

    Tipp... wenn Du eine Datentabelle erstellst, z.B. ein Adressendatenbank,
    gibt SVERWEIS an vorletzter Stelle den Teil aus, den Du brauchst...

    Beispiel...

    an erster stelle steht die Eingabe, z. B. numerisch... (1, 2, 10, 25 usw.)
    an zweiter Stelle steht der Nachname = Müller
    an dritter Stelle findest Du den Vornamen = Fritz
    usw. bist dein DBase gefüllt ist...

    in SVERWEIS gibst Du den Suchbegriff ein der an erster Stelle steht, z. B. '11'...
    die Ausgabe in der Zelle "=SVERWEIS(A1;Tabelle1!A1:B2;2;0)" ergibt jetzt
    den passenden Nachnamen an 11. Stelle; eine 3 Vornamen an 11. Stelle, usw. ...

    Tipp No. 2.... markiere die Tabelle, also in dem die Werte deiner DBase stehen
    und vergebe für den gesamten markierten Bereich einen griffigen Namen ;) ...

    wirst sehen, ist noch einfacher...
     
    #13      
    Ilse_Schnick gefällt das.
  14. Bluesbrother3591

    Bluesbrother3591 Nicht mehr ganz neu hier

    Dabei seit:
    24.02.2012
    Beiträge:
    51
    Geschlecht:
    männlich
    Software:
    Photoshop CS5
    Kameratyp:
    canon EOS 60d
    Excel: wenn dann Funktion zusammenfassen
    #14      
    Ilse_Schnick gefällt das.
  15. Ilse_Schnick

    Ilse_Schnick Aktives Mitglied

    Dabei seit:
    23.09.2005
    Beiträge:
    435
    Geschlecht:
    weiblich
    Ort:
    Bärlin
    Excel: wenn dann Funktion zusammenfassen
    Ja kenn ich, hatte mich zu der Zeit aber nicht weitergebracht, denn ich bin dort nicht registriert... ;)
     
    #15      
x
×
×