Anzeige

Fehlerhafte Darstellung eines Links

Fehlerhafte Darstellung eines Links | PSD-Tutorials.de

Erstellt von doedel_ei, 25.08.2008.

  1. doedel_ei

    doedel_ei Noch nicht viel geschrieben

    Dabei seit:
    06.08.2008
    Beiträge:
    38
    Geschlecht:
    männlich
    Fehlerhafte Darstellung eines Links
    Tach,

    ich habe ein Problem mit einem simplen externen Link. Bei der Darstellung im Browser wird das Wort, dem der Link zugewiesen ist doppelt, einmal mit Link und einmal ohne, dargestellt. Hier der Code:

    Code (Text):
    1. [B][FONT=Arial][SIZE=2][COLOR=blue][COLOR=blue][FONT=Arial]<a  href="http://www.xerox.dk/xtranet+">Xtranet+</a>  [/FONT][/COLOR][/COLOR][/SIZE][/FONT][/B]
    2.  
    Das Ergebnis sieht dann so aus:
    "Xtranet+:Xtranet+"

    Woran kann das liegen? An dem "+"? Das war bisher kein Problem und wurde immer richtig dargestellt.

    Gruß
    doedel_ei
     
    #1      
  2. KnocK

    KnocK Guest

    Fehlerhafte Darstellung eines Links
    AW: Fehlerhafte Darstellung eines Links

    Hi
    du hast zwischen dem <a und dem href ein Leerzeichen zu viel. ;)

    Edit: Hab das mal grad in eine HTML-Datei gepackt und auf meinen Server hochgeladen => http://adcenter.bplaced.net/tests/xtranet.htm
    (einmal mit Leerzeichen und einmal ohne)
    Wird bei mir richtig dargestellt.
    Muss warscheinlich an deinem Browser liegen. Welchen Browser nimmst du?
    Gruß
    AmDr
     
    #2      
  3. doedel_ei

    doedel_ei Noch nicht viel geschrieben

    Dabei seit:
    06.08.2008
    Beiträge:
    38
    Geschlecht:
    männlich
    Fehlerhafte Darstellung eines Links
    AW: Fehlerhafte Darstellung eines Links

    Hoppla, vielen Dank :D

    Ich hab nochmal nachgesehen, der Link wird in einer html Mail dargestellt. Nicht in einem Browser. Hat das einen Einfluss?
     
    #3      
  4. doedel_ei

    doedel_ei Noch nicht viel geschrieben

    Dabei seit:
    06.08.2008
    Beiträge:
    38
    Geschlecht:
    männlich
    Fehlerhafte Darstellung eines Links
    AW: Fehlerhafte Darstellung eines Links

    Schau nochmal richtig hin, das erste "Xtranet+" ist teil des Links! Ich kann heute erst weiter eure Ansätze testen.
     
    #4      
  5. doedel_ei

    doedel_ei Noch nicht viel geschrieben

    Dabei seit:
    06.08.2008
    Beiträge:
    38
    Geschlecht:
    männlich
    Fehlerhafte Darstellung eines Links
    AW: Fehlerhafte Darstellung eines Links

    Habe jetzt deinen Link sowohl im IE6 als auch Firefox 2.0 versucht und bei beiden wird das Ergebnis doppelt dargestellt. Ist schon merkwürdig, dass du es korrekt siehst :hmpf:
     
    #5      
  6. Top_Gun

    Top_Gun Aktives Mitglied

    Dabei seit:
    24.07.2008
    Beiträge:
    965
    Geschlecht:
    männlich
    Fehlerhafte Darstellung eines Links
    AW: Fehlerhafte Darstellung eines Links

    Ähm der Link soll auch doppelt da vorhanden sein...

    Einmal mit dem unnötigen Leerzeichen und einmal ohne das unnötige Leerzeichen im Quelltext...
     
    #6      
  7. stb_87

    stb_87 Web-Sheriff - ohne Bild

    Dabei seit:
    13.05.2007
    Beiträge:
    1.895
    Geschlecht:
    männlich
    Software:
    dies & das
    Fehlerhafte Darstellung eines Links
    AW: Fehlerhafte Darstellung eines Links


    Du kannst da auch fünf Leerzeichen reinhauen... Das ist sowas von egal...
     
    #7      
  8. doedel_ei

    doedel_ei Noch nicht viel geschrieben

    Dabei seit:
    06.08.2008
    Beiträge:
    38
    Geschlecht:
    männlich
    Fehlerhafte Darstellung eines Links
    AW: Fehlerhafte Darstellung eines Links

    Inwiefern "soll" doppelt vorhanden sein? Verstehe deine Aussage nicht ganz :D
     
    #8      
  9. Top_Gun

    Top_Gun Aktives Mitglied

    Dabei seit:
    24.07.2008
    Beiträge:
    965
    Geschlecht:
    männlich
    Fehlerhafte Darstellung eines Links
    AW: Fehlerhafte Darstellung eines Links

    Ich hab nichts anderes behauptet... Unnötg sind sie aber trotzdem, auch wenn es fünfzigtausend wären ;)

    Du hast dich doch auf das Beispiel von AmDr bezogen (oder?) und in diesem Beispiel muss der Link doppelt sein, weil der Link zweimal im Quelltext steht...
    Einmal so:
    HTML:
    1. <a   href="http://www.xerox.dk/xtranet+">Xtranet+</a>
    und einmal so:
    HTML:
    1. <a href="http://www.xerox.dk/xtranet+">Xtranet+</a>
     
    #9      
  10. doedel_ei

    doedel_ei Noch nicht viel geschrieben

    Dabei seit:
    06.08.2008
    Beiträge:
    38
    Geschlecht:
    männlich
    Fehlerhafte Darstellung eines Links
    AW: Fehlerhafte Darstellung eines Links

    Achso. Stimmt. :p

    Um zurück zum Problem zu kommen: hat denn der Browser Einfluss auf die Darstellung in diesem Fall? Da ich es mit zweien getestet habe, wohl eher nicht ne? Da dieser Inhalt in einer HTML Mail drin steht, gibt es da vielleicht eine Besonderheit?
     
    #10      
  11. Top_Gun

    Top_Gun Aktives Mitglied

    Dabei seit:
    24.07.2008
    Beiträge:
    965
    Geschlecht:
    männlich
    Fehlerhafte Darstellung eines Links
    AW: Fehlerhafte Darstellung eines Links

    HTML ist HTML ist HTML (oder so)

    Abgesehen von besonderem Layout oder CSS ist und bleibt HTML in allen Browsern gleich. In diesem Fall bleibt der Link ein Link und wird auch nur als solcher angezeigt. Der Browser macht dabei nur die Formatierung.

    Meiner Meinung nach sollte es in der HTML-Mail genauso sein...
    (Korrigiert mich wenn ich falsch liege)


    Vielleicht liegt dein Problem aber woanders!? Wie wird die Mail denn erstellt?
     
    #11      
x
×
×
teststefan