Anzeige

Glasexperimente / Renderproblem

Glasexperimente / Renderproblem | PSD-Tutorials.de

Erstellt von asturiano, 25.08.2008.

  1. asturiano

    asturiano Profi-Kochlöffelschwenker

    211
    Dabei seit:
    11.08.2008
    Beiträge:
    533
    Geschlecht:
    männlich
    Ort:
    Kölle am Rhing / Hückelhoven
    Software:
    fast alle, die was mit bunten Bildern zu tun haben
    Kameratyp:
    leider keine, letzte ist im Atlantik versunken :(
    Glasexperimente / Renderproblem
    Hallo..
    verzweifel gerade ein bisschen...vielleicht gehe ich das Problem ja auch falsch an...

    Möchte mal ein bisschen Baddesign machen, da ich hier so tolle Badfotos gesehen habe in der gallery...
    Mich faszinieren immer diese Glasbausteine in den Wänden...
    HAbe mal eins modelliert, mit Wölbungen, Verzerrungen usw. sieht toll aus..ABER:

    sobald ich ein Glasmaterial erstelle und dann mehrere Glasbausteine zusammenfüge (gruppiere) geht der Workflow den Bach runter und vor allen renderings dauern tierisch lange .ca 7-8 min bei 12 Steinen (ohne AO)

    Rechner: 5000 X2
    2 GB Ram

    passiert das bei euch auch? oder nehmt ihr einfacheres Glas oder liegt es an der Distorsion der einzelnen Glasbausteinen?

    Vielen Dank für die Hilfe
    Asturiano

    [​IMG]
     
    Zuletzt bearbeitet: 25.08.2008
    #1      
  2. HorstE

    HorstE C4Dler

    Dabei seit:
    20.04.2007
    Beiträge:
    132
    Geschlecht:
    männlich
    Ort:
    Stuttgart
    Software:
    C4D R 11, AR, S&T, Dyn.
    Glasexperimente / Renderproblem
    AW: Glasexperimente / Renderproblem

    Hallo,

    habe gerade mal kurz die Szene nachgestellt und mit einem "Standard"-Glasmaterial rendern lassen. Erst bei einer wesentlich höheren Anzahl 30...40...Würfel wird das Rendern spürbar langsamer (bei 54 Steine ...28 Sec.)...aber ist noch auszuhalten. Probier doch mal ein anderes Glasmaterial.
    (Und ich habe leider auch nur einen ältzeren Hobel AMD 64, 3500+, mit einer Nvidia Geforce 6600 oder so...)
    edit:....oder hast Du Caustics an ?
     
    Zuletzt bearbeitet: 25.08.2008
    #2      
  3. asturiano

    asturiano Profi-Kochlöffelschwenker

    211
    Dabei seit:
    11.08.2008
    Beiträge:
    533
    Geschlecht:
    männlich
    Ort:
    Kölle am Rhing / Hückelhoven
    Software:
    fast alle, die was mit bunten Bildern zu tun haben
    Kameratyp:
    leider keine, letzte ist im Atlantik versunken :(
    Glasexperimente / Renderproblem
    AW: Glasexperimente / Renderproblem

    ..hmmmmm das macht mich aba stutzig :(

    Caustics sind nicht an..
    Glasmaterial ist aus nem Tut mit fresnel und noise-shadern
    mit Banji-Shader siehts bes**** aus...
    Brechungsindex liegt bei meinem Mat bei 1,5

    habe die vermutung das es an meinem Glasbaustein liegt..
    Bei Interesse kann ich die Datei mal hochladen und einer kann das mal bitte checken...
    habe leider noch nicht viel Erfahrung mit Cinema

    lg
    Asturiano

    PS: hier die Datei:
    http://rapidshare.com/files/140183274/Glasbaustein.rar.html

    edit: erst wenn ich bei den Renderoptionen die Brechung deaktiviere geht es einigermaßen mit dem rendern...echt seltsam
     
    Zuletzt bearbeitet: 26.08.2008
    #3      
  4. NF_Darklord

    NF_Darklord Nicht mehr ganz neu hier

    Dabei seit:
    26.04.2008
    Beiträge:
    53
    Geschlecht:
    männlich
    Glasexperimente / Renderproblem
    AW: Glasexperimente / Renderproblem

    versuch mal bei dem Hypernurbs objekt die unterteilung runter zu schrauben, das könnte helfen.
     
    #4      
  5. schnake

    schnake Nicht mehr ganz neu hier

    Dabei seit:
    28.06.2006
    Beiträge:
    248
    Geschlecht:
    männlich
    Ort:
    Reutlingen
    Software:
    C4D R15
    Glasexperimente / Renderproblem
    AW: Glasexperimente / Renderproblem

    @ asturiano kannste des evtl woanders hochladen
    grund: "Als attackierend gemeldete Website!"
    Als attackierend gemeldete Website!

    Die Website auf H**p://antonioaalonso.** wurde als attackierende Seite gemeldet und auf Grund Ihrer Sicherheitseinstellungen blockiert.

    ***info***
    Attackierende Websites versuchen, Programme zu installieren, die private Informationen stehlen, Ihren Computer verwenden, um andere zu attackieren oder Ihr System beschädigen.

    Manche Websites vertreiben bewusst Viren und ähnlich schädliche Software, aber viele Websites sind auch ohne das Wissen oder die Erlaubnis des Betreibers kompromittiert.

    **info ende**
     
    #5      
  6. asturiano

    asturiano Profi-Kochlöffelschwenker

    211
    Dabei seit:
    11.08.2008
    Beiträge:
    533
    Geschlecht:
    männlich
    Ort:
    Kölle am Rhing / Hückelhoven
    Software:
    fast alle, die was mit bunten Bildern zu tun haben
    Kameratyp:
    leider keine, letzte ist im Atlantik versunken :(
    Glasexperimente / Renderproblem
    AW: Glasexperimente / Renderproblem

    Hi Schnake...das ist eine Falschmeldung vom Firefox.

    Google und Firefox arbeiten zusammen.
    Vor einigen Wochen wurde meine Webseite gehackt. Die wurde von mir gelöscht und gesäubert.
    Problem ist das die Unterdomaine von Google inzwischen als sauber deklariert ist, aber anscheinend antonioalonso.de noch nicht..muss mal google bescheid geben, das die die site erneut prüfen.

    ansonsten schau ich mal, wo ich sie sonst uploaden kann...

    lg
    Asturiano

    edit: Downloadlink ist geändert, Datei liegt nun bei rapidshare
     
    Zuletzt bearbeitet: 26.08.2008
    #6      
  7. liquid_black

    liquid_black MOD - 3D

    2
    Dabei seit:
    14.07.2006
    Beiträge:
    3.120
    Geschlecht:
    männlich
    Ort:
    Delmenhorst (bei Bremen)
    Software:
    CS2,Corel Draw 12,Cinema 4d V11.5, Zbrush
    Kameratyp:
    Iphone 4
    Glasexperimente / Renderproblem
    AW: Glasexperimente / Renderproblem

    also das das so lange dauert liegt wahrscheinlich an der shaderart . versuch mal das ganze mit einem anderen shader zu machen . arbeitest du mit displacement ? wenn ja achte darauf das die unterteilungen nicht so hoch sind
     
    #7      
  8. asturiano

    asturiano Profi-Kochlöffelschwenker

    211
    Dabei seit:
    11.08.2008
    Beiträge:
    533
    Geschlecht:
    männlich
    Ort:
    Kölle am Rhing / Hückelhoven
    Software:
    fast alle, die was mit bunten Bildern zu tun haben
    Kameratyp:
    leider keine, letzte ist im Atlantik versunken :(
    Glasexperimente / Renderproblem
    AW: Glasexperimente / Renderproblem

    Hi Liquid Black,

    hmmm, hätte nicht gedacht das Cinema bei Glas so in die Knie geht...wollte hat stylische Glassteine machen..wie man an den Hypernurbs sieht, sind sie sehr aufwändig gestaltet, damit sie realistisch wirken...

    Displacement verwende ich nicht, alle Wölbungen und Reflexe am STein sind per Hypernurbs+extrudieren geformt

    anderen Shader?
    bin leider noch nicht sehr Shader-bewandt.
    das Glas-Mat ist aus nem tut und besteht aus nem noise-Shader und nem Verlaufsshader..zusätzlich ist Fresnel aktiviert, damit das Glas realistisch aussieht..

    @ Darklord:

    kann man auch nachträglich bei Hypernurbs die Unterteilungen runterschrauben oder muss ich nen neuen Baustein basteln ?

    Wie würdet ihr Glasbausteine machen?
    mit ner Foto-Textur?
    oder nur nen gerundetem Würfel ohne Hypernurbs??

    wie gesagt..der Banji-Shader frisst auch Ressourcen und sieht bei weitem nicht so aus wie mein Glasmat aus dem tut..

    Weiß nich, ob man hier Boardfremde tuts verlinken darf, damit ihr des mal anschauen könnt...

    lg
    Asturiano
     
    Zuletzt bearbeitet: 26.08.2008
    #8      
  9. asturiano

    asturiano Profi-Kochlöffelschwenker

    211
    Dabei seit:
    11.08.2008
    Beiträge:
    533
    Geschlecht:
    männlich
    Ort:
    Kölle am Rhing / Hückelhoven
    Software:
    fast alle, die was mit bunten Bildern zu tun haben
    Kameratyp:
    leider keine, letzte ist im Atlantik versunken :(
    Glasexperimente / Renderproblem
    AW: Glasexperimente / Renderproblem

    ..sodele hab jetzt viel rumgespielt..sind ne Menge Faktoren die zusammenspielen....lol

    1. Faktor: viele Glasmaterialien ausprobiert, sobald Diffusionsshader aktiviert ist geht die renderzeit hoch

    2. Faktor: Hypernurbs: je filigraner die Oberflächenstruktur (beveln, extrudieren etc. desdo mehr Renderzeit für das Glasmateiral weil immer mehr Reflexionen entstehen

    3. Anzahl der Lichtquellen

    4. Rendereinstellungen: zumindest bei mir, wenn ich im Konstruktionsmodus bin, sollte ich für Testrender folgende Optionen deaktivieren (weiß nicht, wie es bei euch ist)



    wenn ich viele Glaselemente in der Szene habe:
    a) Antialiasing auf Geometrie anstatt bestes verkürzt um ca. 50 % die Renderzeit
    b) Transparenz: ohne Brechung..verkürzt nochmals ca. 30 % die Renderzeit...

    35 Würfel in dieser Einstellung 10 Sec.
    35 Würfel mit Brechung 47 sec.
    35 Würfel mit Brechung und AA 3:37 Min.

    will gar nicht dran denken wenn ich den Diffusionsshader noch aktiviere...

    folglich komme ich zu dem Schluss, das ich diese Optionen nur bei finalen Rendern aktivieren sollte...dann denke ich mal kommt ne gehörig lange Zeit dabei raus ;)

    also, sollte mir jemand noch andere tipps geben können...gern gesehen :)

    lg Asturiano
     
    #9      
  10. NF_Darklord

    NF_Darklord Nicht mehr ganz neu hier

    Dabei seit:
    26.04.2008
    Beiträge:
    53
    Geschlecht:
    männlich
    Glasexperimente / Renderproblem
    AW: Glasexperimente / Renderproblem

    du kannst auch bei vielen objekten, wie z.B. dem Hypernurbs einstellen, wieviele unterteilungen das objekt im edito udn wieviele im Rendern hat, dadurch lässt sich das objekt leichter bearbeiten.
     
    #10      
  11. asturiano

    asturiano Profi-Kochlöffelschwenker

    211
    Dabei seit:
    11.08.2008
    Beiträge:
    533
    Geschlecht:
    männlich
    Ort:
    Kölle am Rhing / Hückelhoven
    Software:
    fast alle, die was mit bunten Bildern zu tun haben
    Kameratyp:
    leider keine, letzte ist im Atlantik versunken :(
    Glasexperimente / Renderproblem
    AW: Glasexperimente / Renderproblem

    .. Hi :)
    das weiss ich inzwischen, habs ausprobiert..leider gehöre ich zu die Newbies die ständig immer und immer wieder zwischenrendern....sozudagen rendergeil....lol...und je weniger Untertielungen das Hypernurbsobjekt desdo igitter sieht das Bild aus ;)

    ...vielleicht kommt das daher, das ich bei 3D Spielen auch immer die maximalste Deitailtreue brauche..sonst bin ich nich glücklich...

    aber lieben Dank..Dark Lord

    was mein Herz noch beruhigen würde ist die Frage ob das jemand mit ähnlichem Rechner wie ich diese Unterschiede bei dem rendern bestätigen könnte :D
     
    #11      
x
×
×
teststefan