Anzeige

Html zeigt keine bilder an

Html zeigt keine bilder an | PSD-Tutorials.de

Erstellt von maxsteel, 16.10.2009.

  1. maxsteel

    maxsteel Nicht mehr ganz neu hier

    Dabei seit:
    23.11.2008
    Beiträge:
    93
    Geschlecht:
    männlich
    Software:
    CS5
    Html zeigt keine bilder an
    Ich wollte grad was kleines programmieren da kam dieser fehler ich hab aber keine ahnung was das sein kannm, das bild liegt in dem ordner ich hab es auch mit anderen bildern versucht. ich bekomme einfach das bild niht angezeigt was nicht sein kann. denn ich mahc es immer so. wenn ich ein bild per <img> einfür dann zeigt es dieses und das aus dem divlayer mit an sonst zeigt er mir garnichts an
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>Unbenanntes Hallo2</title>
    </head>
    <body>
    <style type="text/css">
    #nav2 {

    background-image:url(img/untergrund.png);
    }
    </style>
    <div id="nav2">

    </div>
    </body>
    </html>
    ich kapiers nicht habt ihr ne idee?
    mfg max
     
    Zuletzt bearbeitet: 16.10.2009
    #1      
  2. sokie

    sokie Mod | Web

    Dabei seit:
    23.03.2008
    Beiträge:
    5.338
    Geschlecht:
    männlich
    Ort:
    Bünde NRW
    Software:
    <br>COREL <br> Texteditor
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an

    nachdem dein DIV keine höhe jat, und leet ist, könnte es daran liegen, dass er keine Ausdehnumg hat, und deshalb nichts zu sehen ist.
    schreib mal etwas inhalt hinein, oder gib ihm einen wert für die höhe (height)
     
    #2      
  3. oxygen

    oxygen PS Azubine

    Dabei seit:
    15.06.2009
    Beiträge:
    1.488
    Geschlecht:
    weiblich
    Ort:
    Berlin
    Software:
    ps cs - ibook g4 os 10.5.8; cs5 web premium (imac) 10.6.4
    Kameratyp:
    meine erste :) nikon 9100
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an

    dein style is nicht im head
     
    #3      
  4. maxsteel

    maxsteel Nicht mehr ganz neu hier

    Dabei seit:
    23.11.2008
    Beiträge:
    93
    Geschlecht:
    männlich
    Software:
    CS5
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an

    Ich hatte schon height: 100%, geht trotzdem nicht.
    Und der style kann hin wo man will.
     
    #4      
  5. Desert_Eagle25

    Desert_Eagle25 Perfektionist

    Dabei seit:
    15.05.2009
    Beiträge:
    51
    Geschlecht:
    männlich
    Ort:
    Allersberg
    Software:
    Photoshop, Gimp
    Kameratyp:
    Panasonic Lumix DMC FZ28
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an

    nein der style kann nicht hin wo er will ... also ja kannst du schon machen, aber dann gehts nicht! schreib ihn in den Head dann wirst du sehen dass es geht und gib dem div eine höhe
    und versuch mal in url() mit "" .. also url ('bild.png');
    lg
     
    #5      
  6. oxygen

    oxygen PS Azubine

    Dabei seit:
    15.06.2009
    Beiträge:
    1.488
    Geschlecht:
    weiblich
    Ort:
    Berlin
    Software:
    ps cs - ibook g4 os 10.5.8; cs5 web premium (imac) 10.6.4
    Kameratyp:
    meine erste :) nikon 9100
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an


    :) na wenn du das sagst

    dann vergiss meinen post
     
    #6      
  7. Tattoomaus78

    Tattoomaus78 nemesis-artgroup.de

    654
    Dabei seit:
    23.08.2005
    Beiträge:
    5.328
    Geschlecht:
    weiblich
    Ort:
    auf und davon
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an

    ...das wär mir ganz neu...das stylesheet (ob zentral im Dokument oder als extern verlinktes) gehört in den head-bereich
     
    #7      
  8. Gerdi_53

    Gerdi_53 Noch nicht viel geschrieben

    Dabei seit:
    31.07.2009
    Beiträge:
    4
    Geschlecht:
    männlich
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an

    Versuche es mal so

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN""http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd" >

    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>Unbenanntes Hallo2</title>
    <style type="text/css">
    #nav2 {


    background-image: url('img/untergrund.png');
    }
    </style>
    </head>
    <body>

    <div id="nav2" >hallo</div>
    </body>
    </html>
     
    #8      
  9. maxsteel

    maxsteel Nicht mehr ganz neu hier

    Dabei seit:
    23.11.2008
    Beiträge:
    93
    Geschlecht:
    männlich
    Software:
    CS5
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an

    ne, geht auch nicht, trotzdem danke. achso wegen dem style das wusste ich nicht ich habs immer anders gemacht nur wenn extewrn dann hab ich <link ...> in head gemacht <style> und </style > hab ich immer unter head. na egal.
    aber was kann da nur sein
     
    #9      
  10. Desert_Eagle25

    Desert_Eagle25 Perfektionist

    Dabei seit:
    15.05.2009
    Beiträge:
    51
    Geschlecht:
    männlich
    Ort:
    Allersberg
    Software:
    Photoshop, Gimp
    Kameratyp:
    Panasonic Lumix DMC FZ28
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an

    ok dann tu mal die 2 raus aus <div id="nav2">
    oder probier mal oben die Doctype Declaration wegzulassen... vllt macht die stress auch wenn ich es nicht glaube
    und dann überprüf nochmal wo dein bild sitzt!
    und dann probier mal verschiedene Browser

    und das <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    kannste weglassen des braucht ma eh net
     
    #10      
  11. oxygen

    oxygen PS Azubine

    Dabei seit:
    15.06.2009
    Beiträge:
    1.488
    Geschlecht:
    weiblich
    Ort:
    Berlin
    Software:
    ps cs - ibook g4 os 10.5.8; cs5 web premium (imac) 10.6.4
    Kameratyp:
    meine erste :) nikon 9100
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an



    ich wollt zwar hier nichts mehr schreiben
    aber wo is die html-einleitung ?





    edit:
    ich kann das elend nicht ertragen


    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <title>mach mal so - damit das mal endet</title>
    <style type="text/css">
    <!--
    body {
    background-image: url(dein-bild.jpg);
    }
    -->
    </style></head>
    <body>
    ........................ divs und navis und was weiss ich
    </body>
    </html>
     
    Zuletzt bearbeitet: 16.10.2009
    #11      
  12. Desert_Eagle25

    Desert_Eagle25 Perfektionist

    Dabei seit:
    15.05.2009
    Beiträge:
    51
    Geschlecht:
    männlich
    Ort:
    Allersberg
    Software:
    Photoshop, Gimp
    Kameratyp:
    Panasonic Lumix DMC FZ28
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an

    hahaha omg da wär net ma ich drauf gekommen, weil des soooo selbstverständlich is!
    des is doch des erste was man schreibt, wenn man anfängt!
    Ja gut da haste dein Problem!
    n1 oxygen
    *lach*

    LG
    Desert Eagle
     
    #12      
  13. oxygen

    oxygen PS Azubine

    Dabei seit:
    15.06.2009
    Beiträge:
    1.488
    Geschlecht:
    weiblich
    Ort:
    Berlin
    Software:
    ps cs - ibook g4 os 10.5.8; cs5 web premium (imac) 10.6.4
    Kameratyp:
    meine erste :) nikon 9100
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an


    das mit dem html is mir auch erst später aufgefallen :)
    mir is nur eingangs der head ins auge gestochen
    eigentlich wollte ich ja nichts mehr in diesen thread schreiben - weil max ja meinte - er könne die styles dahin klatschen - wo es ihm passt ...
     
    #13      
  14. Desert_Eagle25

    Desert_Eagle25 Perfektionist

    Dabei seit:
    15.05.2009
    Beiträge:
    51
    Geschlecht:
    männlich
    Ort:
    Allersberg
    Software:
    Photoshop, Gimp
    Kameratyp:
    Panasonic Lumix DMC FZ28
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an

    ja des stimmt ..
    naja wenn er meint .. dann kann er ja sein style hintun wo er will!!!
    bringt ihm halt nix .. aber gut .. das ist ja net der sinn der sache :D
    ok gut ich glaub der thread ist gelöst oder??
    LG
     
    #14      
  15. maxsteel

    maxsteel Nicht mehr ganz neu hier

    Dabei seit:
    23.11.2008
    Beiträge:
    93
    Geschlecht:
    männlich
    Software:
    CS5
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an

    nein er ist nicht gelöst, es geht nicht, und wo fehlt hier denn derhtml tag? das ist ein normales grundgerüst:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>Unbenanntes Dokument</title>
    </head>

    <body>
    </body>
    </html>

    Also das kann nicht der fehler sein. mir fällt ncihts mehr dazu ein
    hier nochmal alles:

    <html>
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>Unbenanntes Hallo2</title>
    <style type="text/css">
    #nav2 {
    height:100px;
    background-image: url('img/untergrund.png');
    }
    </style>
    </head>
    <body>

    <div id="nav2" >
    </div>
    </body>
    </html>

    mfg max
     
    #15      
  16. mrbuff76

    mrbuff76 Nicht mehr ganz neu hier

    Dabei seit:
    18.11.2008
    Beiträge:
    82
    Geschlecht:
    männlich
    Ort:
    Leipzig
    Software:
    CS5.5
    Kameratyp:
    Canon EOS 350D
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an

    Also entweder der Pfad zum Bild ist nicht korrekt, oder aber - was für einen Browser nutzt du? - es liegt am Bild selbst.

    Hatte vor zwei Wochen auch so einen Fall, dass das Bild im FF korrekt angezeigt wurde, aber im IE nix zu sehen war. Und die Lösung damals war das Bild an sich. Es hatte irgendwie einen Treffer. Hab es neu gespeichert und dann ging es auf einmal.
     
    #16      
  17. maxsteel

    maxsteel Nicht mehr ganz neu hier

    Dabei seit:
    23.11.2008
    Beiträge:
    93
    Geschlecht:
    männlich
    Software:
    CS5
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an

    ich utze firefox der ist jea eigentlich der beste und ich hab getestet der pfad ist richtig denn wenn ich in den divlaer <img scr...> mach dann zeigt es mir das <img> bild an und das aus dem style
     
    #17      
  18. mrbuff76

    mrbuff76 Nicht mehr ganz neu hier

    Dabei seit:
    18.11.2008
    Beiträge:
    82
    Geschlecht:
    männlich
    Ort:
    Leipzig
    Software:
    CS5.5
    Kameratyp:
    Canon EOS 350D
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an

    Das ist seltsam. Ich hab deinen Code genommen und es mal mit einem Bild von mir getestet. Ging auf Anhieb.

    Gib mal deinem #nav2 eine Border, also border: 1px solid black;
    Dann kannst du sehen, ob der DIV-Conatiner überhaupt dargestellt wird.
     
    #18      
  19. maxsteel

    maxsteel Nicht mehr ganz neu hier

    Dabei seit:
    23.11.2008
    Beiträge:
    93
    Geschlecht:
    männlich
    Software:
    CS5
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an

    er wird dargestellt der border das bild aber nciht hier mal die ordner struktur:

    test
    ->index.php
    ->img (ordner)
    -> untergrund.png

    und code: background-image: url('img/untergrund.png');
    mfg max
     
    #19      
  20. mrbuff76

    mrbuff76 Nicht mehr ganz neu hier

    Dabei seit:
    18.11.2008
    Beiträge:
    82
    Geschlecht:
    männlich
    Ort:
    Leipzig
    Software:
    CS5.5
    Kameratyp:
    Canon EOS 350D
    Html zeigt keine bilder an
    AW: Html zeigt keine bilder an

    Du, ich hab da so eine Idee... Änder mal den Ordnernamen in z.B. images!
     
    #20      
Seobility SEO Tool
x
×
×