Kritik zu erstem Entwurf

Kritik zu erstem Entwurf | Seite 4 | PSD-Tutorials.de

Erstellt von Waegi, 05.12.2012.

  1. Raphale

    Raphale angehender Webentwickler

    Dabei seit:
    09.10.2012
    Beiträge:
    87
    Geschlecht:
    männlich
    Kritik zu erstem Entwurf
    AW: Kritik zu erstem Entwurf

    #navi ul li {width:100px;height:30px;background-color:003d8f;}
    #navi ul li a {height:100%,,,height:30px,,,,padding:22px 20px 19px 20px}

    da musst du einfach alle varianten mal durchprobieren ^^

    Die Browser haben auch unterschiedlich automatisches Padding bei rändern oder kp was allem ^^ scheiß IE zickt immer am meisten
     
    #61      
  2. TutKit

    TutKit Vollzugriff

    Vollzugriff auf sämtliche Inhalte für Photoshop, InDesign, Affinity, 3D, Video & Office

    Suchst du einen effektiven Weg, um deine Geschäftsideen aber auch persönlichen Kenntnisse zu fördern? Teste unsere Lösung mit Vollzugriff auf Tutorials und Vorlagen/Erweiterungen, die dich schneller zum Ziel bringen. Klicke jetzt hier und teste uns kostenlos!

  3. Raphale

    Raphale angehender Webentwickler

    Dabei seit:
    09.10.2012
    Beiträge:
    87
    Geschlecht:
    männlich
    Kritik zu erstem Entwurf
    AW: Kritik zu erstem Entwurf

    wenn du nur noch einen browser hast der rumzickt...dann empfiehlt sich ein hack!!
     
    #62      
  4. Waegi

    Waegi Aktives Mitglied

    Dabei seit:
    14.02.2011
    Beiträge:
    337
    Geschlecht:
    männlich
    Software:
    Adobe Photoshop CS5, InDesign CS5, Illustrator CS5
    Kameratyp:
    Canon EOS 1100D
    Kritik zu erstem Entwurf
    AW: Kritik zu erstem Entwurf

    Ja ok, aber ich muss ja den Links den Backgroundgeben, damit diese mit ihrem Background anklickbar sind und nicht nur der Text, genau so soll auch oberhalb des Textes der Hover aktiviert werden, nicht nur auf dem Text, das ist das Problem, das wird oben nicht immer funktionieren, aber ich teste mal ein paar Sachen und werde mich dann hier nochmal melden.
     
    #63      
  5. Waegi

    Waegi Aktives Mitglied

    Dabei seit:
    14.02.2011
    Beiträge:
    337
    Geschlecht:
    männlich
    Software:
    Adobe Photoshop CS5, InDesign CS5, Illustrator CS5
    Kameratyp:
    Canon EOS 1100D
    Kritik zu erstem Entwurf
    AW: Kritik zu erstem Entwurf

    So, habs auch schon gelöst bekommen, vielen Dank an Raphale für den entscheidenen Tipp, für alle die die Lösung auch gerne wissen möchten, hier der CSS-Code:
    Code (Text):
    1. #navi ul{margin:0 0 0 320px;}
    2. #navi ul li a.active{background:#003d8f; color:#acd305;}
    3. #navi ul li a{color:#003d8f; float:left; height:50px; padding:24px 20px 0 20px;}
    4. #navi ul li a:hover{background:#003d8f; height:50px; color:#acd305;}
     
    #64      
  6. Waegi

    Waegi Aktives Mitglied

    Dabei seit:
    14.02.2011
    Beiträge:
    337
    Geschlecht:
    männlich
    Software:
    Adobe Photoshop CS5, InDesign CS5, Illustrator CS5
    Kameratyp:
    Canon EOS 1100D
    Kritik zu erstem Entwurf
    AW: Kritik zu erstem Entwurf

    Also, ich hab mal wieder ein Problem, hab seit langem wieder an der Website gearbeitet.
    Nun ist es so, ich möchte die Website ja responsive machen und da gerne einen Teil über Media Queries lösen, jedoch ist es so, ich hab die Elemente absolut positioniert, damit ich die Navibar und das Logo übereinander legen kann, nehm ich die absolute positionierung raus, dann liegen die Elemte nicht richtig übereinander, also das eine leicht nach oben versetzt. Versetz ich das dann nach unten, wird die komplette Website nach unten versetzt.

    Nun möchte ich aber in den Media Queries die Breite automatisch regeln, jedoch geht das nicht, wenn die Elemente absolut positioniert sind.

    Hier mal nen Link, wo ich die aktuellen Dateien hochgeladen habe: http://waegi.square7.ch/cms/

    Weiß dabei jemand Rat?

    mfg Waegi
     
    #65      
  7. Waegi

    Waegi Aktives Mitglied

    Dabei seit:
    14.02.2011
    Beiträge:
    337
    Geschlecht:
    männlich
    Software:
    Adobe Photoshop CS5, InDesign CS5, Illustrator CS5
    Kameratyp:
    Canon EOS 1100D
    Kritik zu erstem Entwurf
    AW: Kritik zu erstem Entwurf

    Weiß denn niemand Rat?
     
    #66      
  8. GrafFoto

    GrafFoto Noch nicht viel geschrieben

    Dabei seit:
    15.12.2012
    Beiträge:
    11
    Geschlecht:
    männlich
    Kritik zu erstem Entwurf
    AW: Kritik zu erstem Entwurf

    Warum müssen Logo und Navi denn übereinander liegen?
    Floate sie doch nebeneinander, dann kannst du das position rausnehmen:

    #logo{width:283px; height:131px; padding:0 0 0 15px; z-index:20; float: left;}

    #navi{background:#acd305; width:702px; height:74px; z-index:1; margin:20px 0 0 0; float: right; ...
     
    #67      
  9. Waegi

    Waegi Aktives Mitglied

    Dabei seit:
    14.02.2011
    Beiträge:
    337
    Geschlecht:
    männlich
    Software:
    Adobe Photoshop CS5, InDesign CS5, Illustrator CS5
    Kameratyp:
    Canon EOS 1100D
    Kritik zu erstem Entwurf
    AW: Kritik zu erstem Entwurf

    Ich habs mittlerweiel anderst gelöst, das war aus dem Grund, damit ich rechts die Abrundung an der Navi bekomm und den Schatten auch, wenn ich dem Logo die Abrundung dort geb und den Schatten, dann wird der Schatten an der Bildgrenze gesetzt und nicht an den Ecken der Seite, hab es mittlerweile jetzt gelöst über ein paar Tricks, war nen bissle schwieriger bis ich drauf gekommen bin, habs auch erst vor nen paar Minuten geschafft, aber danke für deine Antwort.

    Für alle die die Lösung sehen möchen, könnt sie unter dem Link von oben anschauen.

    Mfg Waegi
     
    #68      
Seobility SEO Tool
x
×
×