Anzeige

link in einem custom field ausgeben

link in einem custom field ausgeben | PSD-Tutorials.de

Erstellt von susiH, 21.02.2011.

  1. susiH

    susiH Aktives Mitglied

    Dabei seit:
    04.12.2008
    Beiträge:
    267
    Geschlecht:
    weiblich
    link in einem custom field ausgeben
    hi leute,
    ich habe gerade versucht ein custom field mit einem link zu versehen. das feld wird auch angezeigt, aber die links sind nicht klickbar.
    muss man sowas dass vielleicht anders ausgeben?

    das ist der code, wie das feld ausgegeben wird
    PHP:
    1.  
    2.            <?php
    3.            $kunden = get_post_meta($post->ID, "kunden", false);
    4.            if ($kunden[0]=="") { ?>
    5.            <!-- If there are no custom fields, show nothing -->
    6.            <?php } else { ?>
    7.            <div class="kunden">
    8.                    <h3>alle kundenreferenzen</h3>
    9.                 <?php foreach($kunden as $kunden) {
    10.                 echo '<p>'.$kunden.'</p>';
    11.                 } ?>
    12.            </div>
    13.            <?php } ?>
    14.  
    und hier könnt ihr ja mal gucken, wie die links letztendlich aussehen
    werk zwei
     
    #1      
  2. zutrinken

    zutrinken I hate Sundays

    Dabei seit:
    23.09.2009
    Beiträge:
    223
    Geschlecht:
    männlich
    Ort:
    Berlin
    link in einem custom field ausgeben
    AW: link in einem custom field ausgeben

    ich denke warum das nicht klickbar ist, ist dass diese "bildshow" über den gesamten bereich liegt...
     
    #2      
  3. susiH

    susiH Aktives Mitglied

    Dabei seit:
    04.12.2008
    Beiträge:
    267
    Geschlecht:
    weiblich
    link in einem custom field ausgeben
    AW: link in einem custom field ausgeben

    kann man denn darin keine links ausgeben?
     
    #3      
  4. zutrinken

    zutrinken I hate Sundays

    Dabei seit:
    23.09.2009
    Beiträge:
    223
    Geschlecht:
    männlich
    Ort:
    Berlin
    link in einem custom field ausgeben
    AW: link in einem custom field ausgeben

    klar...der link wird auch ausgegeben, aber da liegt der Slider drüber, was man allerdings nicht sieht...ausser man schaut in den code. Normalerweise sollte ja auch der Text-Cursor erscheinen wenn man über die Texte geht, was aber nicht der fall ist.

    Also an deiner Customfield-Ausgabe liegt es nicht.
     
    #4      
x
×
×