Anzeige

Poser 7 / Probleme mit Gangdesigner

Poser 7 / Probleme mit Gangdesigner | PSD-Tutorials.de

Erstellt von toomsen, 09.10.2008.

  1. toomsen

    toomsen Noch nicht viel geschrieben

    Dabei seit:
    23.09.2008
    Beiträge:
    27
    Geschlecht:
    männlich
    Kameratyp:
    Canon EOS 550 D
    Poser 7 / Probleme mit Gangdesigner
    Hi Leute,

    ich hab hier keine Fragen zum Thema gefunden. Hoffentlich ist trotzdem ein Spezi hier, der helfen kann. Ich krieg den Poser 7 Gangdesigner bzw. auch den bereits fertig designten Gang nie so manipuliert, wie ich das möchte.

    In diesem Fall habe ich, für ein klassisches Adventure, eine Lauf- und eine Stehanimation und möchte die beiden nun aneinander anpassen. D.h. die Stehanimation (Arme sind verschränkt) soll mit dem ersten / letzten Bild der Laufanimation (Arme offen) beginnen, dann in die Stehhaltung übergehen und wieder zurück.

    Nun krieg ich aber weder die Figur transformiert, noch das gesamte Bild / Frame kopiert und wieder eingefügt. Es wird jeweils nur eine merkwürdige Verdrehung des ganzen Körpers. :'(

    Bitte händeringend um einen Tipp, wie ich auch nur annähernd weiterkomme.
     
    #1      
  2. TheJack

    TheJack Aktives Mitglied

    Dabei seit:
    07.10.2008
    Beiträge:
    541
    Geschlecht:
    männlich
    Software:
    C4D 10.5 Studio, Poser 7pro, PS CS3
    Poser 7 / Probleme mit Gangdesigner
    AW: Poser 7 / Probleme mit Gangdesigner

    Hi,
    Du sagst (nein schreibst) das Du eine Stand und eine walk animation hast, haste die selber in Poser gemacht oder als BVH importiert?

    Ansonsten solltest Du beim ersten und letzten Frame einen Keyframe mit deiner standpose erstellen (einfach den kleinen Schlüßel ganz unten rechts drücken) dann zu dem gewünschten frame "gehen" und die Ani einfügen.

    Wenn das nicht geht hab ich auch noch ne Idee;)
    Aber verusch es erstmal

    Grüße TheJack
     
    #2      
  3. Jojographics

    Jojographics DersichdenWolfpixelt

    Dabei seit:
    04.09.2008
    Beiträge:
    48
    Geschlecht:
    männlich
    Ort:
    bei Aachen
    Software:
    Lightwave, Photoshop, Vue, Poser, After FX, Premiere, Magix Video Studio
    Kameratyp:
    Panasonic HDC TM60, Nikon D3000
    Poser 7 / Probleme mit Gangdesigner
    AW: Poser 7 / Probleme mit Gangdesigner

    Hi!

    Einzelne Keyframe(posen), ob nun für einen Körperteil oder die gesamte Figur kannst du in der Menü/Animation/Animationpalette hin und her kopieren (einfach anklicken copy und paste).
    Wenn Du bei deinen Schlüsselposen immer wieder Verdrehungen drin hast, würde ich erstens mal schauen, ob nicht die y-Rotationen für Hip, Body, Abdomen, Chest etc. bei den Parametern nicht komplett andere Werte haben, als in dem jeweils anderen Bewegungszustand (Laufen/Stehen). Arbeitest Du mit IK? Es hilft manchmal auch diese für die beiden Beine abzuschalten. Wenn nämlich bei angeschalteter IK die Füsse nicht da stehen, wo sie sein sollten, gibt es auch lustige Verdrehungen.
    Ich bin selber gerade dabei einige Bewegungen aufzubauen, habe aber den Walkdesigner umgangen und BVH Daten benutzt (bekommst Du massenweise frei im Netz). Die Ergebnisse beim Walkdesigner sehen für mich oft nicht sehr überzeugend aus.

    Es gibt auch ein paar nette Tools, die da helfen können. Schau doch mal bei Renderosity und suchen nach "molsmith". Der hat einige ein paar Tools entwickelt.

    Gruss

    Jochen
     
    Zuletzt bearbeitet: 14.10.2008
    #3      
  4. toomsen

    toomsen Noch nicht viel geschrieben

    Dabei seit:
    23.09.2008
    Beiträge:
    27
    Geschlecht:
    männlich
    Kameratyp:
    Canon EOS 550 D
    Poser 7 / Probleme mit Gangdesigner
    AW: Poser 7 / Probleme mit Gangdesigner

    @thejack

    Hi,

    die Keyframes bearbeiten gelingt mir ja inzwischen halbwegs, aber in diesem Punkt geht nix. Ich hab eine (korrekte) Standposition nur in einer anderen Datei zusammengewurschtelt gekriegt. Aber die Position krieg ich natürlich nicht in das erste und letzte Frame der Gehanimation.

    Inzwischen hab ich beide lediglich angeglichen, so daß der Übergang im Spiel kaum noch sichtbar ist. Aber wenn du da noch ne andere Idee in der Schublade hast... her damit.

    herzlichen gruß
    toomsen
     
    #4      
  5. toomsen

    toomsen Noch nicht viel geschrieben

    Dabei seit:
    23.09.2008
    Beiträge:
    27
    Geschlecht:
    männlich
    Kameratyp:
    Canon EOS 550 D
    Poser 7 / Probleme mit Gangdesigner
    AW: Poser 7 / Probleme mit Gangdesigner

    @jojographics

    Hi,

    Ik ist aktiviert. Der Gang an sich ist inzwischen - trotz Gangdesigner :) - ok. Die Gelenkverdrehungen hab ich inzwischen auch im Griff. Das ganze Problem war halt, daß man nicht so ohne weiteres eine Stehpose an den Anfang der Gehanimation setzen kann. Inzwischen ist mir aber auch klargeworden, daß das nochmals sehr viele Frames erfordern würde (Stehpose-Übergang zu Laufanimation-Laufanimation-Übergang zu Stehpose-Stehpose). Ich schätze, da ist man eh besser beraten das zu trennen und einzeln ins Spiel einzubauen.

    gruß
    toomsen
     
    #5      
  6. TheJack

    TheJack Aktives Mitglied

    Dabei seit:
    07.10.2008
    Beiträge:
    541
    Geschlecht:
    männlich
    Software:
    C4D 10.5 Studio, Poser 7pro, PS CS3
    Poser 7 / Probleme mit Gangdesigner
    AW: Poser 7 / Probleme mit Gangdesigner

    Hi toomsen,

    1)
    also die Pose (halt Deine Steh-Ani und Walk-Ani) solltest du einfach in der Poser-libary(unter Pose) speichern.Kannste später ja wieder löschen.

    2)sagen wir Du willst eine Animation von 300 Frames, gehe auf Frame 1 und lade deine gespeicherte Pose (Steh-Ani),klick nun besagten Schlüßel.

    3)Geh auf Frame 300 und klicke den Schlüßel erneut.

    4)Gehe nun auf einen Belibiebigen Frame und lade die Walk-Ani.

    5)Fertig.:D

    Die Verdrehungen kannste auch über den Graph Editor editieren.

    Ich hoffe wirklich das ich Deine Frage jetzt überhaubt richtig verstanden habe, ansonsten Sorry

    Grüße TheJack
     
    #6      
  7. Jojographics

    Jojographics DersichdenWolfpixelt

    Dabei seit:
    04.09.2008
    Beiträge:
    48
    Geschlecht:
    männlich
    Ort:
    bei Aachen
    Software:
    Lightwave, Photoshop, Vue, Poser, After FX, Premiere, Magix Video Studio
    Kameratyp:
    Panasonic HDC TM60, Nikon D3000
    Poser 7 / Probleme mit Gangdesigner
    AW: Poser 7 / Probleme mit Gangdesigner

    Hi und wie schon gesagt, mir hat es oft geholfen, die einfach abzuschalten, da es manchmal bei eben solchen Kombis von Posen und Animationen zu merkwürdigen ergebnissen kommen kann.

    Ahsooooo!!! Nee, das ist eigenlich klar. Auf Zwischenschritte oder neudeutsch "inbetweens" (für jedes bewegte Objekt) musst Du natürlich achten. Da wäre der Vorschlag von TheJack eigentlich schon zu empfehlen.
    Trennen ist auch eine Lösung, dann müssen natürlich die Ansätze zwischen den einzelnen Teilen exakt passen und somit eigentlich fast das Gleiche machen wie bei der Animation am Stück. sonst hüpft und springt es u.U. in der fertigen Animation. Viel Glück und lass´mal sehen, wenn es fertig ist. :)

    Gruss

    Jochen
     
    Zuletzt bearbeitet: 15.10.2008
    #7      
  8. toomsen

    toomsen Noch nicht viel geschrieben

    Dabei seit:
    23.09.2008
    Beiträge:
    27
    Geschlecht:
    männlich
    Kameratyp:
    Canon EOS 550 D
    Poser 7 / Probleme mit Gangdesigner
    AW: Poser 7 / Probleme mit Gangdesigner

    @the jack

    hi thejack,

    werd das morgen mal in die Tat umzusetzen versuchen. Mit der Framezahl liegtst du beinahe richtig. Auf so ne Zahl wirds ungefähr hinauslaufen.

    @jojographics

    Hi Jochen,

    das lass ich gern sehen wenns fertig ist. Keine Frage. Das Ganze wird übrigens ein Adventure. Mal schauen obs gelingt, wie ich mir das denke. Aber den -hoffentlich - funktionierenden Animationsteil über den wir hier reden, werd ich natürlich vorab posten.

    gruß
    toomsen
     
    #8      
x
×
×
teststefan