Anzeige

probelme bei veröffenlichen ab flashplayer 6

probelme bei veröffenlichen ab flashplayer 6 | PSD-Tutorials.de

Erstellt von justyes_, 19.09.2008.

  1. justyes_

    justyes_ Guest

    probelme bei veröffenlichen ab flashplayer 6
    hallo,
    bin neu hier und muß euch leider schon mit einem problem "nerven".
    bei meiner bildergallerie funktioniert alles soweit ganz gut (bei veröffenlichen auf flashplayer 6 gestellt / actionscript 1+2 funtionieren), stelle ich aber dann um auf flashplayer 7, 8,.. werden keine bilder mehr angezeigt!!!!!
    ich benötige aber version 8, da ich die gallerie in einem anderen (neueren) fla-dokument verwenden muß.

    bitte, bitte erbarmt sich einer, diesem nervigen problem.
    ps: leider bin ich nicht sonderlich gut in flash (aber bemüht;))

    also:
    fehlermeldung:
    Fehler beim Öffnen der URL 'file:///Macintosh%20HD/Users/xxxxxxxxxxx/Desktop/Flash%5Fkack%5F/my%5Fphp%5Ftry%5F/undefined'


    und fla-datei.
     
    #1      
  2. lucy186

    lucy186 Pixelschubser

    Dabei seit:
    08.03.2007
    Beiträge:
    189
    Geschlecht:
    weiblich
    probelme bei veröffenlichen ab flashplayer 6
    AW: probelme bei veröffenlichen ab flashplayer 6

    Magst Du Deine Fla-Datei bereitstellen? So ist das schwer zu sagen…
     
    #2      
  3. justyes_

    justyes_ Guest

    probelme bei veröffenlichen ab flashplayer 6
    AW: probelme bei veröffenlichen ab flashplayer 6

    ...dann versuch ichs mal so.

    // XML-Objekt erzeugen (Bezeichner: mein_xml)
    mein_xml = new XML();

    // Störende Leerzeichen ignorieren
    mein_xml.ignoreWhite = true;

    // XML-Datei einlesen
    mein_xml.load("bilddaten.xml");

    // Lesevorgang
    mein_xml.onLoad = function(status) {
    if (status && this.loaded) {
    anzahl = mein_xml.firstChild.childNodes.length;
    geladen = true;
    aktbild = 0;
    ladeBild(aktBild);
    }
    };

    // Funktion, welche die Daten der XML-Datei verarbeitet
    function ladeBild(paktBild) {
    status_mc._visible = 1;
    bild = mein_xml.firstChild.childNodes[paktBild].attributes.pic;
    bildname = mein_xml.firstChild.childNodes[paktBild].attributes.name;
    loadMovie(bild, "bild_mc");
    titel_txt.text = bildname;
    }

    // Weiter Schalter
    weiter_btn.onRelease = function() {
    if (geladen && aktbild<anzahl-1) {
    aktbild++;
    ladeBild(aktBild);
    }
    };

    // Zurück Schalter
    zuruck_btn.onRelease = function() {
    if (geladen && aktbild>0) {
    aktbild--;
    ladeBild(aktBild);
    }
    };

    stop();
     
    #3      
  4. justyes_

    justyes_ Guest

    probelme bei veröffenlichen ab flashplayer 6
    AW: probelme bei veröffenlichen ab flashplayer 6

    hallo lucy186, hast du schon ne ahnung was man am code oben änder müsste,
    ich verzweifle...;(
     
    #4      
  5. lucy186

    lucy186 Pixelschubser

    Dabei seit:
    08.03.2007
    Beiträge:
    189
    Geschlecht:
    weiblich
    probelme bei veröffenlichen ab flashplayer 6
    AW: probelme bei veröffenlichen ab flashplayer 6

    tritt das Problem direkt nach dem veröffentlichen auf oder erst, wenn Du das swf. in den anderen Film lädtst?
    Ich brauch noch einen Moment… ich hatte so ein ähnliches Problem vor 2-3 Wochen – muss eben rausfinden was ich geändert habe…
     
    #5      
  6. justyes_

    justyes_ Guest

    probelme bei veröffenlichen ab flashplayer 6
    AW: probelme bei veröffenlichen ab flashplayer 6

    Problem tritt sofort bei film-testen auf, egal ob gespeichert oder nicht, hab auch alle möglichen varianten der "Veröffentlichung" versucht...
     
    #6      
  7. lucy186

    lucy186 Pixelschubser

    Dabei seit:
    08.03.2007
    Beiträge:
    189
    Geschlecht:
    weiblich
    probelme bei veröffenlichen ab flashplayer 6
    AW: probelme bei veröffenlichen ab flashplayer 6

    Ich find jetzt so keinen Fehler… stimmen Deine Pfad-Angaben zu den benutzten Dokumenten alle? Also auch im XML-Dokument? Funzt nur mit relativen Pfaden, sonst gibts ne Sicherheitsverletzung…
     
    #7      
  8. justyes_

    justyes_ Guest

    probelme bei veröffenlichen ab flashplayer 6
    AW: probelme bei veröffenlichen ab flashplayer 6

    vielen Dank soweit, ich kann auch immer noch keinen Fehler finden. Voreinstellungen auf fp6 = alles läuft, Einstellungen auf fp8 kein Bild mehr...
    brauch mal en break, setz mich später nochmal ran. trotzdem vielen dank.
     
    #8      
  9. lucy186

    lucy186 Pixelschubser

    Dabei seit:
    08.03.2007
    Beiträge:
    189
    Geschlecht:
    weiblich
    probelme bei veröffenlichen ab flashplayer 6
    AW: probelme bei veröffenlichen ab flashplayer 6

    Ansonsten hab ich gerade noch was gefunden, dass das mit sRGB-Profil manchmal nicht funzt (keine Ahnung ob das stimmt)… Sorry, mehr kann ich Dir im Moment auch nicht sagen. Vielleicht noch einmal im Flash-Forum posten? Tut mir leid, ich hätte Dir gern weiter geholfen!
     
    Zuletzt bearbeitet: 19.09.2008
    #9      
x
×
×
teststefan