Anzeige

Problem mit Apache2 und RewriteRule

Problem mit Apache2 und RewriteRule | PSD-Tutorials.de

Erstellt von bad2be, 25.09.2008.

  1. bad2be

    bad2be Aktives Mitglied

    Dabei seit:
    14.12.2005
    Beiträge:
    641
    Geschlecht:
    männlich
    Ort:
    Ludwigshafen am Rhein
    Problem mit Apache2 und RewriteRule
    Huhu Ihrs
    Irgendwie fühl ich mich grad noch dümmer als sonst :)
    Ich möchte im Apache eine rewriterule deffinieren, habe glaub ich mittlerweile 1000 google Suchergebnisse Durch, aber funtionieren tut erst nichts.
    Ich habe in meiner Apache httpd.conf folgende Zeile angehängt:
    Code (Text):
    1.  
    2. Include "c:/wamp/apache2/conf/htaccess/sdcms.conf"
    3.  
    Untre diesem Pfad sollen meine Rewriterules liegen, diese sollte so aussehen:

    Code (Text):
    1. RewriteEngine On
    2. RewriteRule ^index_([0-9]+).htm$ index.php?id=$1
    3.  
    Jetzt sollte doch, wenn ich die URL:
    localhost/testseite/index_1.htm aufrufe eigentlich an index.php?id=1 dabei rauskommen, oder versteh ich da was falsch?
    Das tut es eben nicht.
    mod_rewrite ist als Apache_handler eingeladen, sagt zumindest die phpinfo().
    Kann mir vielleicht jemand helfen, oder liegt es (wie ich mittlrweile vermute) an meinem Apache? Egal wie ich die Rewrite gestalte bekomme ich immer einen 404 not found.

    Vielen Dank im Voraus für Eure Hilfe

    LG B2B

    Edit:
    Achja,
    Apache Version Apache/2.0.58 (Win32) PHP/5.1.4
    Apache API Version 20020903

    Edit2: Die Errorlogs geben nichts zurück :(
     
    Zuletzt bearbeitet: 25.09.2008
    #1      
  2. bad2be

    bad2be Aktives Mitglied

    Dabei seit:
    14.12.2005
    Beiträge:
    641
    Geschlecht:
    männlich
    Ort:
    Ludwigshafen am Rhein
    Problem mit Apache2 und RewriteRule
    AW: Problem mit Apache2 und RewriteRule

    Grüss Dich
    Erstmal vielen Dank. Hatte schon gehofft das Du recht hast, leider aber kein Erfolg. Zunächst includet Apache schon von Haus aus die

    Include "c:/wamp/apache2/conf/alias/phpmyadmin.conf"
    Include "c:/wamp/apache2/conf/alias/sqlitemanager.conf"

    Und wenn ich Blödsinn in den Includeten Dateien mache fährt der Apache gar net rauf.
    Includen sollte also gehen.
    Ach, und selbst wenn ich die Rewrites direkt in die httpd.conf schreibe funtioniert es nicht (404 not found).

    LG B2B
     
    #2      
  3. netbandit

    netbandit Aktives Mitglied

    12
    Dabei seit:
    18.05.2008
    Beiträge:
    1.145
    Geschlecht:
    männlich
    Problem mit Apache2 und RewriteRule
    AW: Problem mit Apache2 und RewriteRule

    Such mal in der httpd.conf nach

    LoadModule rewrite_module modules/mod_rewrite.so

    Wenn das noch eine Raute (#) vor ist, lösch das mal.

    Ist bei mir so (XAMPP)
     
    #3      
  4. Puschkin

    Puschkin Noch nicht viel geschrieben

    Dabei seit:
    11.09.2008
    Beiträge:
    24
    Geschlecht:
    männlich
    Problem mit Apache2 und RewriteRule
    AW: Problem mit Apache2 und RewriteRule

    Probiere es mal mit einem / vor index.php
     
    #4      
  5. bad2be

    bad2be Aktives Mitglied

    Dabei seit:
    14.12.2005
    Beiträge:
    641
    Geschlecht:
    männlich
    Ort:
    Ludwigshafen am Rhein
    Problem mit Apache2 und RewriteRule
    AW: Problem mit Apache2 und RewriteRule

    Nope, leider net ;(

    Auch nicht :(

    Hat sich aber erledigt, vielen Dank
    Habs jetzt über .htaccess geregelt.
    ist zwar n bisschen langsamer, aber mein gott, was solls^^
    Danke nochmal,

    LG B2B
     
    Zuletzt bearbeitet: 25.09.2008
    #5      
x
×
×
teststefan