Anzeige

[Problem:Navigation]IE vs Doctype

[Problem:Navigation]IE vs Doctype | PSD-Tutorials.de

Erstellt von LowkaZ, 22.07.2006.

  1. LowkaZ

    LowkaZ Half Life

    Dabei seit:
    19.01.2006
    Beiträge:
    697
    Geschlecht:
    männlich
    Ort:
    Dudweiler
    Software:
    Textmate, WordPress, jQuery, PHP5, MySQL, CSS3, HTML5
    Kameratyp:
    Leica
    [Problem:Navigation]IE vs Doctype
    Ich hab ein Joomla Menu extrahiert Transmenu, so hab den code sauber rausgetrennt funktioniert im FF auch wunderbar.

    Code (Text):
    1. <html xmlns="http://www.w3.org/1999/xhtml">
    2. <head>
    3. <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    4. <title>Unbenanntes Dokument</title>
    5.  
    6. <link rel="stylesheet" type="text/css" href="transmenu.css" />
    7. <script type="text/javascript" src="transmenu.js"></script>
    8.  
    9. </head>
    10.  
    11. <body>
    12. <div id="navigation" style="display:none"></div>
    13.  
    14.  
    15. <?
    16. include('menu.php');
    17. ?>
    18.  
    19. </div>
    20. </body>
    21. </html>
    22.  


    Natürlich hat m$ IE scheißdreck wie immer probleme damit... nach ein bisschen probieren hab ich den fehler gefunden...

    es liegt am Doctype
    Code (Text):
    1.  
    2. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    3.  
    Hat jmd hierfür ne Lösung?

    Der Fehler der entsteht ist dass das Menu versetzt wird und nicht direkt unter den menupunkt gesetzt wird...

    Hier die Links

    http://ralf.hortt.de/developer/transmenu/
    http://ralf.hortt.de/developer/transmenu/falsch/
     
    #1      
  2. Quaese

    Quaese Noch nicht viel geschrieben

    Dabei seit:
    18.06.2006
    Beiträge:
    31
    [Problem:Navigation]IE vs Doctype
    Hi,

    das Problem im IE entsteht, da er in der ersten Version aufgrund der fehlenden Dokumentendeklaration in den Quirksmode (fehlertolerander Modus) geschaltet wird. In der zweiten Variante läuft der IE im Almost Standards Mode und die Grössenangaben werden strikter eingehalten.

    Als Lösung kannst Du mal versuchen, die Höhen für Viewport und Body auf 100 Prozent zu setzen. Die Aussen- und Innenabstände des Bodys werden Null gesetzt.
    Code (Text):
    1. body, html{ height: 100%;}
    2. body{ margin: 0;
    3.       padding: 0;}
    4.  
    Willst Du das Menue mit Abständen versehen, kann das zum Beispiel über einen zusätzlichen äusseren DIV-Container geschehen.

    Vielleicht hilft Dir das weiter.

    Ciao
    Quaese
     
    #2      
  3. LowkaZ

    LowkaZ Half Life

    Dabei seit:
    19.01.2006
    Beiträge:
    697
    Geschlecht:
    männlich
    Ort:
    Dudweiler
    Software:
    Textmate, WordPress, jQuery, PHP5, MySQL, CSS3, HTML5
    Kameratyp:
    Leica
    [Problem:Navigation]IE vs Doctype
    hat leider nicht geholfen :-/
    Ich hasse IE...
    ständig geht er mir aufen sack...
    und wenn man anfängt hacks einzubauen kann man gar nicht mehr aufhören :-(
     
    #3      
x
×
×