Anzeige

R14 - Sculpting backen, Displacement - unsaubere Oberfläche im Rendering

R14 - Sculpting backen, Displacement - unsaubere Oberfläche im Rendering | PSD-Tutorials.de

Erstellt von comitzuu, 10.01.2013.

  1. comitzuu

    comitzuu Noch nicht viel geschrieben

    Dabei seit:
    14.12.2012
    Beiträge:
    10
    Geschlecht:
    männlich
    Ort:
    Wiesbaden
    Software:
    Cinema, Adobe, FCPX, Motion
    Kameratyp:
    EOS 7D
    R14 - Sculpting backen, Displacement - unsaubere Oberfläche im Rendering
    Schönen guten Tag,

    ich bin noch neu hier im Forum und deswegen mit der ein oder anderen Vorgehensweise noch nicht so recht bewandert, aber erst einmal grüße ich alle sehr herzlich!

    Mit meiner Problemstellung habe ich nicht nur dieses Forum hier durchforstet, sondern in den letzten Tagen jeden möglichen Beitrag und jedes zugängliche Tutorial im Internet, nur leider finde ich keinen Lösungsansatz.

    Ich habe mich an der Sculptingfunktion in R14 betätigt und erhalte leider ein sehr unsauberes Endergebnis, nach dem Texturen backen auf dem Low-Mesh, was die Oberflächenstruktur anbelangt.


    Vorgehensweise:

    Lowmesh schrittweise nach oben hin verfeinert (wobei das Lowmesh bereits über 8982 Polygone verfügt). Stufe 3 reichte mir somit von der Polygonanzahl locker aus für saubere Konturen wie ich sie benötige, hier beläuft sich die Anzahl der Polygone auf 574.496. Die UV-Map ist ebenfalls sauber abgewickelt, ohne dass sich dort UW-Polygone überschneiden.

    Soweit so gut.

    Nach Fertigstellung im Sculpting habe ich die Backen-Funktion betätigt und dies in jedem Format versucht, welches hier möglich ist, angefangen bei der kleinsten Größe 512 x 512 bis hin zu 4k x 4k. Supersampling stand auf 0 (mit 1 wird es auch nicht besser), den Pixelrand habe ich bei 5 stehen lassen. Der Haken bei Ergebniskopie erstellen ist gesetzt.

    Gebacken habe ich alle 3 Texturen, also Displacement, Normalen und Ambient Occlusion. Da ich bis Stufe 5 moduliert habe, aber das Ergebnis der Stufe 3 mir vollkommen ausreicht, habe ich den Haken gesetzt bei "Obere Stufen einschließen" (wobei ich es auch ohne versucht habe).

    Dann habe ich beim Quellobjekt die Stufe 3 gewählt und beim Zielobjekt die Stufe 0.

    Da ich mich an der Animation des Charakters versuchen möchte, habe ich bei den Displacement-Einstellungen RGB (XYZ Tangente) gewählt und bei den Normalen-Einstellungen ebenfalls Tangente.

    So wie erwartet, erhalte ich nun ein LowMesh-Objekt mit den entsprechenden Texturen in den jeweiligen Materialkanälen.

    Wird das komplette Objekt im Editor gerendert, so ist das Ergebnis auch absolut in Ordnung.


    Problem:

    Die Naheinstellung des Gesichtes. Um die Augenpartien herum, an der Nase und dem Mund gibt es im Rendering eine komplett unsaubere Oberflächenstruktur. Komischerweise nur im Gesicht. Am Bauch etc. ist alles in Ordnung. Da innerhalb der Animation eine Naheinstellung des Gesichtes benötigt wird, ist das sehr hinderlich. Gewünscht wird hier die gleiche glatte Oberfläche wie es im Rendering des High-Mesh auftritt.
    Ich würde auch das High-Mesh verwenden, aber da streikt, insbesondere bei der Animation, die Technik, bzw. bin ich alt und grau bis das Ergebnis dann fertig gestellt ist.

    Auch nochmals die Sculptin-Funktion aufzurufen und die Oberfläche zu glätten hilft nicht.

    Ich habe auch in den Materialkanälen versucht die Konfigurationen besser abzustimmen, Texturen auszublenden etc., aber egal was ich versuche, wenn überhaupt, so wird es nur noch schlimmer…

    In den Rendervoreinstellungen ist unter Antialiasing "Bestes" eingestellt von 1 x 1 bis 4 x 4. Die Optionen sind bei den Voreinstellungen geblieben, wobei es das alles nicht wirklich sein kann. Das High-Mesh verfügt ja im Rendering über eine saubere spiegelglatte Oberfläche...

    Der Fehler tritt übrigens lediglich in Verwendung der Displacement-Textur auf.

    Hier sind noch entsprechende Screenshots als PDF:

    http://cs.hosteurope.de/bildbeispiele/bildbeispiele.pdf

    Ich wäre super Dankbar, wenn mir jemand meinen Denkfehler beseitigen könnte, oder mich zumindest auf die richtige Fährte bringt…!

    Vielen Dank
     
    Zuletzt bearbeitet: 10.01.2013
    #1      
  2. KBB

    KBB Blaubär

    Dabei seit:
    18.03.2009
    Beiträge:
    8.518
    Geschlecht:
    männlich
    Software:
    C4D | CS PP 5.5 | Andere
    R14 - Sculpting backen, Displacement - unsaubere Oberfläche im Rendering
    AW: R14 - Sculpting backen, Displacement - unsaubere Oberfläche im Rendering

    Auf jeden Fall ist schonmal die Auflösung des Gesichtsbereiches extrem klein, vergleich mal den Bereich der Polygone um Augen und Nase mit beispielsweise dem Bein links daneben. Da dort idR. ziemlich viele Details Platz finden können, sollte der Bereich allein schon so groß sein wie Deine restliche Map, auf jeden Fall aber schonmal 1-2K.
     
    #2      
  3. little_polarbear

    little_polarbear Aktives Mitglied

    21
    Dabei seit:
    17.06.2009
    Beiträge:
    471
    Geschlecht:
    weiblich
    Software:
    Cinema 4D R.17, VRAY, Photoshop
    R14 - Sculpting backen, Displacement - unsaubere Oberfläche im Rendering
    AW: R14 - Sculpting backen, Displacement - unsaubere Oberfläche im Rendering

    dann würde ich auch noch UVWs fortführen im Sculpting Fenster anklicken. Dadurch wird das meistens schonmal ein bisschen sauberer.

    Wie KBB schon gesagt hat, ist der Bereich um die Augen/Mund sehr klein, der sollte auf jedenfall größer sein.

    Versuch mal als Displacement Map RGB (XYZ Objekt) oder Intensität. Bei meinen Sculptingsachen war es so, dass bei dem einem Character die RGB (XYZ Objekt) Map sauber war, dagegen Intensität eine Katastrophe. Oder zum Teil auch umgekehrt. Das hängt immer von dem Charakter und dem Mesh ab. Bei einem konnte ich die Displacement Map überhaupt nicht verwenden und musste dann meine Normal Maps als Displacement Map benutzen, was bei diesem Charakter zum Glück ging. Was noch eine andere Möglichkeit wäre: Backe deinen Charakter von Stufe 3 auf 1. Das hilft manchmal auch.

    Um ehrlich zu sein, ist es manchmal eine ziemliche Rumprobiererei bis man die passenden Einstellungen gefunden hat.
     
    #3      
  4. comitzuu

    comitzuu Noch nicht viel geschrieben

    Dabei seit:
    14.12.2012
    Beiträge:
    10
    Geschlecht:
    männlich
    Ort:
    Wiesbaden
    Software:
    Cinema, Adobe, FCPX, Motion
    Kameratyp:
    EOS 7D
    R14 - Sculpting backen, Displacement - unsaubere Oberfläche im Rendering
    AW: R14 - Sculpting backen, Displacement - unsaubere Oberfläche im Rendering

    Siehe da, erst wenn man denkt, man habe jeden erdenklichen Weg versucht, darf man erkennen, dass viele Dinge gar nicht so kompliziert sind, wie man sie sich gemacht hat…

    Bingo…! Ihr liegt absolut richtig und ich spreche euch meinen tiefsten Dank aus!

    Das umstrukturieren der UV-Map und den Haken setzen bei "UVs fortsetzen", sowie die prinzipielle Vergrößerung der Maps war der Schlüssel zum gewünschten Ergebnis. Jetzt sind mir gleich einige Sachverhalte klarer geworden! Tangente konnte ich übrigens stehen lassen, aber für künftige Aufgabenstellungen merke ich es mir auch die anderen Konfigurationen zu versuchen.

    Ganz lieben Dank…!
     
    #4      
x
×
×