Anzeige

[utf-8] Alles richtig, aber ...

[utf-8] Alles richtig, aber ... | PSD-Tutorials.de

Erstellt von Curanai, 15.03.2013.

  1. Curanai

    Curanai Aktives Mitglied

    Dabei seit:
    20.08.2011
    Beiträge:
    363
    Geschlecht:
    männlich
    Ort:
    Oldenburg
    Software:
    Notepad++
    [utf-8] Alles richtig, aber ...
    Hallo PSD'ler,

    ich muss nun leider auch mal eine utf-8 Frage an den Mann/die Frau bringen, da ich mit meiner Lösung (es gibt eine!) so gar nicht einverstanden bin. Vorab: Nein, ich habe keine Probleme mit Umlauten, Sonderzeichen o. ä. - es geht um ein anderes "Detail".

    Alle meine Projekte sind wie folgt "aufgestellt":
    - Datenbankverbindung und Felder in utf-8
    - Dateikonvertierung utf-8 ohne BOM
    - META-Angabe utf-8
    - AddCharset in htaccess auf utf-8

    Ich habe keine Probleme mit "german umlauts" - ich kann auch kyrillisch verwenden o. ä. und der Browser sagt bei "auto. Zeichensatz" direkt "utf-8". Alles hübsch und funktional, sollte man meinen ...

    Was liefert mir der ResponseHeader? "text/html" - und keine Angabe zu utf-8. Dieses Fehl sorgt dafür, dass ein externes Programm (installiert im OS, kompatibel mit akt. Windows-Version usw.) dann anfängt, das allen bekannte "?" zu zeigen - und schlimmer.

    Aber jetzt kommt der Clou ja noch: Schicke ich dieser Seite dann auch noch unnötiger Weise (meiner Meinung nach) einen "Content-Type" als header() aus PHP mit, geht es im besagten Tool korrekt und der ResponseHeader trägt dann auch endlich "utf-8" mit ... (aber der Aufwand ist mir "deutlich zu blöd" dies dann überall zu erweitern).

    Eigentlich spricht das ganze Internet von "joar, kannst mit htaccess in den Griff kriegen" (AddCharset) - nö. Alle anderen Angaben, die oben gemacht sind, greifen auch nur bedingt (Datenbank ja eh net dafür).

    Ich befürchte also, dass ich einen Denkfehler irgendwo habe - meine einzige Idee wäre noch gewesen, dass es eine htaccess geben muss, die höher liegt als meine und dann auch den Cache so komisch aushebelt. Ein grandioses Hoch auf Server, welche administriert werden (im Preis inkl.).

    Hat jemand von euch eine fruchtende Idee oder kann mich in die richtige Klippe schubsen? Letztendlich geht es nur um "Wieso eigentlich nicht?!"

    Vielen Dank.
     
    #1      
  2. Bertram_Heinrichs

    Bertram_Heinrichs Aktives Mitglied

    1
    Dabei seit:
    11.02.2013
    Beiträge:
    1.770
    Geschlecht:
    männlich
    Software:
    Photoshop CC, Nikon Capture NX2, DxO Optics Pro 9
    Kameratyp:
    Nikon D5100, Nikon D3100
    [utf-8] Alles richtig, aber ...
    AW: [utf-8] Alles richtig, aber ...

    Ein korrekter Header ist nicht unnötig, sondern das a und o:

    <!DOCTYPE html>
    <html>
    <head>
    <meta charset="UTF-8">
    <title>HTML Template</title>
    </head>
    <body>
    <p>Insert content here.</p>
    </body>
    </html>

    (nach w3.org)
     
    #2      
  3. Curanai

    Curanai Aktives Mitglied

    Dabei seit:
    20.08.2011
    Beiträge:
    363
    Geschlecht:
    männlich
    Ort:
    Oldenburg
    Software:
    Notepad++
    [utf-8] Alles richtig, aber ...
    AW: [utf-8] Alles richtig, aber ...

    Bertram, vielen Dank für Deine Antwort - ich meine aber nicht das <head>-Tag in einer HTML-Datei (was übrigens nicht wirklich ausreicht, um utf-8 korrekt zu verwenden), sondern den "RespsonseHeader", der vom Server mit der angeforderten Seite ausgeliefert wird, welcher bspw. so aussieht:

    Code (Text):
    1. Date: Sat, 16 Mar 2013 11:53:10 GMT  
    2. Server: Apache
    3.  Pragma: no-cache  
    4. Cache-Control: maxage=1209600, public  
    5. Expires: Sat, 30 Mar 2013 11:53:10 GMT  
    6. Content-Language: de  
    7. Keep-Alive: timeout=2, max=200  
    8. Connection: Keep-Alive
    9.  Transfer-Encoding: chunked  Content-Type: text/html; charset=utf-8
    Wie eingangs erwähnt: Es ist alles korrekt auf utf-8 gesetzt, allerdings würde ich gern auf PHP header() (daher steht es in diesem Bereich und nicht bei den Scriptsprachen) verzichten und es lieber regulärer lösen.

    Vielleicht liege ich ja dann auch thematisch hier ganz falsch - und nicht wundern: utf-8 steht jetzt dabei, weil der header() gesetzt ist. ;)

    Ich suche also den Grund, warum die Darstellung (daher in diesem Bereich des Forums) der ausgelieferten Seite - trotz aller gesetzten und empfohlenen Befehle für utf-8 - dennoch das Charset nicht mitschickt ... dies dann nur, wenn noch zusätzlich der Content-Type via header() gesetzt wird. Würde ich keine Scriptsprache verwenden, wird es auch gehen müssen ...

    Vielen Dank.
     
    #3      
  4. teste123

    teste123 Aktives Mitglied

    Dabei seit:
    14.01.2012
    Beiträge:
    499
    Geschlecht:
    männlich
    [utf-8] Alles richtig, aber ...
    #4      
  5. Curanai

    Curanai Aktives Mitglied

    Dabei seit:
    20.08.2011
    Beiträge:
    363
    Geschlecht:
    männlich
    Ort:
    Oldenburg
    Software:
    Notepad++
    [utf-8] Alles richtig, aber ...
    AW: [utf-8] Alles richtig, aber ...

    Im Moment denke ich, dass ich Suaheli rede. Und nochmal: Protokoll HTTP 1.1 ... RFC 2616 ... ich gebe einen Link zurück, worum es geht. Ziemlich genauer noch hier: klick.

    Ich benötige keine Übersicht über Entitäten, Unicode oder HTML-Tags, da die inhaltliche Darstellung korrekt ist. Danke dennoch.
     
    #5      
  6. 1A_Photoshop

    1A_Photoshop Nicht mehr ganz neu hier

    Dabei seit:
    06.06.2012
    Beiträge:
    191
    Geschlecht:
    männlich
    Ort:
    Berlin
    Software:
    Photoshop
    Kameratyp:
    Fuji S5 Pro und Canon 600d
    [utf-8] Alles richtig, aber ...
    AW: [utf-8] Alles richtig, aber ...

    @Curanai,

    ich weiß nicht welches Problem genau du hast. Versteh es nicht ganz.
    Aber ich hatte auch mal ein Problem in diese Richtung.

    Einmal lag es an meinem Editor (damals phase5) da konnte ich noch so viel im Klartext utf-8 reinschreiben, der hat das dann in die Dateien (das was man nicht sieht) wieder umgewandelt.
    Also vielleicht liegt es an deinem Editor.

    Ein anderes Server-Problem habe ich hinbekommen, in dem ich an erste Stelle erst einmal, das eingefügt habe.
    Code (Text):
    1. <?php header("Content-Type: text/html;charset=utf-8"); ?>
    Wie gesagt, ich weiß nicht ob dir das hilft.
     
    #6      
  7. Curanai

    Curanai Aktives Mitglied

    Dabei seit:
    20.08.2011
    Beiträge:
    363
    Geschlecht:
    männlich
    Ort:
    Oldenburg
    Software:
    Notepad++
    [utf-8] Alles richtig, aber ...
    AW: [utf-8] Alles richtig, aber ...

    Hallo Viktor, jetzt kommen wir langsam in das Gewässer, wo ich schon schwimme - mehr oder weniger hilflos.

    Also: Mein viel zu zuverlässiger Editor Notepad++ arbeitet optimal in so ziemlich allen Konvertierungen - auch sind alle Bereiche wirklich utf-8. Den Editor klammer ich ganz aus ... aber eben nicht den Server.

    Doch genau diesen Eintrag, den Du mir vorschlägst, will ich eben nicht systemweit ergänzen müssen. Ich habe auch Probleme mit dem Cache, da es wohl - so die Theorie - eine übergeordnete htaccess geben muss, die alle Cache-Settings meint vornehmen zu müssen (nein, die sehe ich nicht und kann auf diese auch nicht zugreifen).

    Ich habe jetzt meine htaccess komplett umgekrempelt und so ziemlich viele Dinge berücksichtigt (X-UA, AddCharset, deflate, ...) ... und obwohl alles total berechtigt enthalten ist, bekomme ich dennoch viele Dinge nicht in den Griff. Andere Server melden über den Server, dass er bspw. gzip gar nicht unterstützen würde, utf-8 wird nur als "text/html" ausgegeben usw.

    Wie ich schon schrieb: Würde ich kein PHP parsen wollen, müsste ich dennoch doch utf-8 in den ResponseHeader geprügelt bekommen ...

    Das steht bei mir in der htaccess - bevor wer fragt:
    AddDefaultCharset utf-8
    AddCharset utf-8 .atom .css .js .json .rss .vtt .xml


    ... und noch viele Cache-Dinge, die korrekt gesteuert werden müssen (Mobilgeräte!). Und was bekomme ich? Folgendes ...

    Code (Text):
    1. Expires: Thu, 19 Nov 1981 08:52:00 GMT
    2. Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    3. Pragma: no-cache
    Aber das kommt nicht von mir (!!!). Meine htaccess (root; aus meiner Anmelde-Ebene) quillt über mit Dingen wie ExpiresDefault, ExpiresByType ... auch "deflate" wie erwähnt scheint gar nicht auszuliefern aufgrund dieser "höheren Instanz".

    Setze ich einen Content-Type (es ist ja wohl das kleinste Übel), scheint der wieder überschrieben zu werden - es kommt kein Wert via Header an. Setze ich einen Vary, verschwindet auch der ...

    Ja, es handelt sich bei dem Vieh um einen "administrierten Server" - aber eigentlich soll sich in dem Bereich gar nichts abspielen ... in meinen Augen kann es nur eine höhere htaccess sein - doch wie blockiert die dann Kommandos innerhalb einer TLD?

    Vielen Dank.
     
    #7      
  8. 1A_Photoshop

    1A_Photoshop Nicht mehr ganz neu hier

    Dabei seit:
    06.06.2012
    Beiträge:
    191
    Geschlecht:
    männlich
    Ort:
    Berlin
    Software:
    Photoshop
    Kameratyp:
    Fuji S5 Pro und Canon 600d
    [utf-8] Alles richtig, aber ...
    AW: [utf-8] Alles richtig, aber ...

    Vielleicht liegt es doch am Editor, ich wollte das damals auch nicht glauben.
    Es kommt nicht auf das Sichtbare an, sondern was der intern abspeichert.
    Und Notepad hatte zumindest früher Problem damit.
    s.h. http://www.flashforum.de/forum/am-rande/notepad-utf-8-problem-184945.html

    Bei allem Anderen bin ich überfragt.
    Aber probiere mal einen anderen Editor. Kostet ja nur reinladen und einmal neu abspeichern.
     
    #8      
  9. Curanai

    Curanai Aktives Mitglied

    Dabei seit:
    20.08.2011
    Beiträge:
    363
    Geschlecht:
    männlich
    Ort:
    Oldenburg
    Software:
    Notepad++
    [utf-8] Alles richtig, aber ...
    AW: [utf-8] Alles richtig, aber ...

    Selbst Office öffnet das Ding als utf-8 (da korrekt erkannt) ... :D (hat auch kein Byte-Order-Mark).

    Dein Link ist acht Jahre (!) alt und der letzte Themenschreiber spricht von einem falschen Plugin (falsche Sprache), wo er ähnliches erlebt habe ...

    Danke dennoch ...
     
    #9      
  10. 1A_Photoshop

    1A_Photoshop Nicht mehr ganz neu hier

    Dabei seit:
    06.06.2012
    Beiträge:
    191
    Geschlecht:
    männlich
    Ort:
    Berlin
    Software:
    Photoshop
    Kameratyp:
    Fuji S5 Pro und Canon 600d
    [utf-8] Alles richtig, aber ...
    AW: [utf-8] Alles richtig, aber ...

    Ich sage dir nur, ich hatte das selbe Problem mit phase5 damals. Da hab ich auch überall utf-8 reingeschrieben und musste mich belehren lassen, dass der intern das anders abspeichert.

    Übrigens ist Office kein Test ob das utf-8 übertragen wird oder nicht.

    Ich wollte dir nur helfen und dir sagen das ich es auch nicht glauben wollte das bestimmte Editoren kein UTF-8 ( intern abspeichern) können.

    Du kannst jetzt noch eine weile Suchen oder es einfach mal ausprobieren. Dann hast du dieses Problem dann wirklich zu 100% ausgeschlossen.
     
    #10      
  11. Myhar

    Myhar Hat es drauf

    Dabei seit:
    01.11.2007
    Beiträge:
    2.046
    Geschlecht:
    männlich
    Ort:
    Ö
    [utf-8] Alles richtig, aber ...
    AW: [utf-8] Alles richtig, aber ...

    Du schreibst von damals ;) Und notepad++ wird, wie phase5 aktiv entwickelt und gerne verwendet (unter anderem von mir) und ich kann auch sagen, dass Files als utf-8 abgespeichert werden. Zumindest hatte ich nie Probleme damit :)
    Soweit hat mein Post leider nur am Rande etwas mit dem Problem zu tun, ich würde den Fehler auch am Server suchen. Jedoch kann ich hier nicht viel weiter helfen, sorry.
     
    #11      
  12. 1A_Photoshop

    1A_Photoshop Nicht mehr ganz neu hier

    Dabei seit:
    06.06.2012
    Beiträge:
    191
    Geschlecht:
    männlich
    Ort:
    Berlin
    Software:
    Photoshop
    Kameratyp:
    Fuji S5 Pro und Canon 600d
    [utf-8] Alles richtig, aber ...
    AW: [utf-8] Alles richtig, aber ...

    Ja ich sag auch nicht, dass ich Recht habe. Ich weiß nur, damals war es ein Problem.
    Manch einer arbeitet ja auch mit alten Editoren.

    Vielleicht hilft das ein wenig, aber wahrscheinlich auch nicht.:
    https://hpv.leo.uberspace.de/wordpress/ansi-utf8-problem/
     
    #12      
x
×
×