Anzeige

Video fehler

Video fehler | PSD-Tutorials.de

Erstellt von enforcer31, 17.04.2008.

  1. enforcer31

    enforcer31 Guest

    Video fehler
    Hallo,

    ich habe eine eine Seite auf der rechts unten per Button verschiedene
    Videos ablaufen sollen
    Bei Button 1 soll Vid1 laufen .. bei Button 2 soll Vid 2 laufen.
    Natürlich soll bei drücken den Button 2 das erste Video stoppen und verschwinden.
    Soweit hab ich da auch hinbekommen.
    Leider wird aber entweder nur die Musik des Videos geladen oder es startet erst gar nicht.
    Ich möchte eigendlich gar nicht den Skin "ClearoverAll.swf" laufen lassen.
    also hab ich den ausgeschaltet.
    AutoPlay ist auch off.

    Screenshot:
    [​IMG]


    Hier das AS (Flash 8 Pro):

    Code (Text):
    1.  
    2. my_nc.connect(null);
    3. // NetStream-Objekt erstellen und onStatus()-Funktion definieren
    4. var my_ns:NetStream = new NetStream(my_nc);
    5. my_ns.onStatus = function(infoObject:Object):Void {
    6. status_txt.text += "status (" + this.time + " seconds)\n";
    7. status_txt.text += "\t Level: " + infoObject.level + "\n";
    8. status_txt.text += "\t Code: " + infoObject.code + "\n\n";
    9. };
    10. // NetStream-Videofeed an das Video-Objekt anhängen
    11. my_video.attachVideo(my_ns);
    12. // Zwischenspeicherzeit festlegen
    13. my_ns.setBufferTime(5);
    14. // Wiedergabe der FLV-Datei starten
    15. my_ns.play("energie09.052.flv");
    16.  
    Hier die Button settings:

    Code (Text):
    1.  
    2. vid2_flv._visible = false;
    3.  
    4. vid1_btn.onRelease =function  () {
    5.     vid1_flv._visible = true;
    6.     vid2_flv._visible = false;
    7.     my_ns.pause();
    8.     my_video.clear();
    9.    
    10.    
    11.    
    12. }
    13.  
    14. vid2_btn.onRelease =function  () {
    15.     vid1_flv._visible = false;
    16.     vid2_flv._visible = true;
    17.     my_ns.pause();
    18.     my_video.clear();
    19.            
    20.  }
    21.  
    Kann mir jemand bitte helfen, dass energie09.052.flv gleich beim laden der Seite läuft...alse nicht nur Ton sondern auch der Film?

    Und jeweils per Button der eine film gestoppt wird und der 2te abläuft?
     
    Zuletzt von einem Moderator bearbeitet: 17.04.2008
    #1      
  2. caro_2008

    caro_2008 geflasht

    Dabei seit:
    24.02.2008
    Beiträge:
    86
    Geschlecht:
    weiblich
    Ort:
    Berlin
    Video fehler
    AW: Video fehler

    Ehrlich gesagt, weiß ich noch nicht genau, wo dein Problem ist.
    Für dein Vorhaben, wenn ich es richtig versteh,würde ich einfach wie folgt vorgehen.

    stop();

    var verbindung:NetConnection = new NetConnection();
    verbindung.connect(null) ;
    var stream:NetStream = new NetStream(verbindung);
    myvideo.attachVideo(stream);

    stream.setBufferTime(10);
    stream.play("movie_01.flv");


    video1_btn.onRelease = function(){
    stream.pause();
    stream.play("movie_01.flv");

    }

    video2_btn.onRelease = function(){
    stream.pause();
    stream.play("movie_01.flv");

    }

    LG
     
    #2      
  3. enforcer31

    enforcer31 Guest

    Video fehler
    AW: Video fehler

    Danke für Deine Antwort.

    Leider läuft der Film nicht.
    Man kann nur den Ton hören.
    Das Bild bewegt sich nicht:'(
     
    #3      
  4. caro_2008

    caro_2008 geflasht

    Dabei seit:
    24.02.2008
    Beiträge:
    86
    Geschlecht:
    weiblich
    Ort:
    Berlin
    Video fehler
    AW: Video fehler

    Hast du schon mal andere Filme gestestet, ob der Fehler da auch auftaucht? Vielleicht hat der Film an sich ein Fehler. Du kannst auch mal versuchen, das flv mit dem VLC-Player abzuspielen. Sollte klappen.

    Ansonsten...hmmm...Beispiel online stellen, dann kann man das einfacher debuggen.
     
    #4      
  5. enforcer31

    enforcer31 Guest

    Video fehler
    AW: Video fehler

    Die Filme wurden richtig importiert.
    Wenn ich einen Skin benutze, z.B. ClearoverALL.swf
    dann läuft der Film, wenn ich Play drücke.

    Erst wollte ich auch den Skin benutzen, aber wenn ich mir gerade Vid1 anschaue und dann auf den Button für Vid2 drücke, dann läuft Vid1 weiter
    und stoppt nicht und man hört den Ton von Vid1 beim betrachten des Vid2.

    Über dieses AS (benutze Deins + _visible) hört Vid1 auf, wenn ich auf Vid2 Button drücke, aber die Videos laufen ja nicht..man sieht das erste Bild des Films und es läuft nur der Ton.

    Ich bin am verzweifeln.

    Ich schick Dir mal nen Link für dieses .FLA
     
    Zuletzt von einem Moderator bearbeitet: 17.04.2008
    #5      
  6. enforcer31

    enforcer31 Guest

    Video fehler
    AW: Video fehler

    Problem mittels ContentLoader gelöst.

    @Caro:

    Bitte lösche meine Files die ich Dir gesendet hab.
    Danke!
     
    #6      
x
×
×