Antworten auf deine Fragen:
Neues Thema erstellen

Antworten zum Thema „flash-film im Internet Explorer falsch positioniert“

drummer02

Noch nicht viel geschrieben

Ich hab ein Problem und zwar wird eine Diashow, die ich mit flash erstellt habe, im Internet Explorer falsch positioniert. Das Problem tritt aber nur im Internet Explorer auf, in allen anderen Browsern gibts keine Positionierungsprobleme. Hat das vielleicht was mit dem embed-tag zu tun Den gibts doch glaub nur wegen/für den IE...aber bis jetzt hab ich auch noch keine Attribute für den embed-tag gefunden, mit dem man die Position von dem flash-film angeben kann (z.B. top, left, usw...)
Achja: die html-datei des flash-films befindet sich in einem DIV.
Hat jemand eine Idee woran die falsche Positionierung im IE liegen könnte ?
 

drummer02

Noch nicht viel geschrieben

AW: flash-film im Internet Explorer falsch positioniert

ok...hier ist der Link:
Internationales Christliches Zentrum Sindelfingen
ich hab den Tip mit dem Rahmen auch schon ausprobiert...das seltsame: der Rahmen erscheint (im IE) praktisch bei 2(!) DIVs: Einmal um den richtig positionierten DIV (der keinen Inhalt aufweist) und einmal um den falsch positionierten flash-Film in der linken unteren Ecke. Warum gibts da im IE auf einmal 2 DIVs, wenn ich den doch nur einmal in der index-datei stehen hab ??
 

drummer02

Noch nicht viel geschrieben

AW: flash-film im Internet Explorer falsch positioniert

ok, den rahmen hab ich jetzt hingemacht. wenn du im IE GANZ nach rechts scrollst, müsstest du den verschobenen flash-film eigentlich sehen...
 

drummer02

Noch nicht viel geschrieben

AW: flash-film im Internet Explorer falsch positioniert

ok, also die validierungs-geschichte werd ich dann jetzt wohl in Angriff nehmen (müssen).
der DIV mit dem flash-film heißt "rightNews".
Das </div> vor dem </object> hab ich auch mal weggemacht. das sollte keine DIV-box "schließen", sondern dafür sorgen, dass eine bestimmte Formatierung aufgehoben wird (<div class="textformatierung">blabla</div>)
also nur dass keine Missverständnisse aufkommen. aber war natürlich trotzdem Quatsch, das Element hatte da nix zu suchen.
 

drummer02

Noch nicht viel geschrieben

AW: flash-film im Internet Explorer falsch positioniert

<object type="application/x-shockwave-flash" data="http://www.security-tipp.de/archiv/videos/zaunsequenz_gross.swf" width="200" height="150">
<param name="movie" value="http://www.security-tipp.de/archiv/videos/zaunsequenz_gross.swf" />
<a href="http://forum.sobers.de/viewtopic.php?f=2&t=57" target="_blank"><img src="/images/noflash.gif" width="200" height="150" alt="Install Adobe&reg; Flash Player" border="" /></a>
</object>

Dann brauch ich in dem Fall den embed-tag gar nicht mehr ?
Das wär ja cool !
 

drummer02

Noch nicht viel geschrieben

AW: flash-film im Internet Explorer falsch positioniert

ich hab jetzt diesen WC3 tip von dir anstelle des alten Gebildes eingesetzt, aber auf
HTML / XHTML / XML / WML Validator werden immer noch Fehler aus dem embed-tag angezeigt...obwohl sich die aktualisierte datei schon aufm Server befindet...was mach ich da falsch ?
 

drummer02

Noch nicht viel geschrieben

AW: flash-film im Internet Explorer falsch positioniert

noch was anderes: ich dacht mir, warum setz ich nich einfach !important ein? so kann ich ja extra Angaben für den IE machen...
das sind die Eigenschaften des DIVs, in dem sich der flash-film befindet:
HTML:
#rightNews {
    position:absolute;
    margin-right:0px;
    top:202px !important;
    top:101px;  /*für IE 8.0*/
    left:762px !important;
    left:381px; /*für IE 8.0*/
    width:219px; 
    height:405px;
    padding:0px; 
    overflow:visible; 
    z-index:3;
    background-color:#CCCCFF;}
zufällig hab ich rausgekriegt, dass ich die halbierten Werte bei left und top eintragen müsste, damit der DIV auch im IE richtig positioniert wird. Deswegen wär das mit dem !important ja cool...
Eigentlich müsste das doch so funktionieren...
tut's halt aber nicht...weißt du vielleicht warum ?
 

drummer02

Noch nicht viel geschrieben

AW: flash-film im Internet Explorer falsch positioniert

hi, ok die website ist jetzt nach HTML 4.01 Transitional valide.
das problem: die flash-diashow ist im IE immer noch verschoben...:(
ich weiß jetzt wirklich nicht mehr woran das liegen kann...
auch kein ungeschlossener DIV mehr...
der html-code der diashow sieht sogar exakt gleich aus wie der html-code des banners (klar, bis auf die maße und die dateipfade)
*ratlos bin*
 

drummer02

Noch nicht viel geschrieben

AW: flash-film im Internet Explorer falsch positioniert

Weiß denn wirklich niemand eine Lösung ? Wär wirklich wichtig für mich, wenn ich das Problem lösen könnte !!
 
Bilder bitte hier hochladen und danach über das Bild-Icon (Direktlink vorher kopieren) platzieren.
Antworten auf deine Fragen:
Neues Thema erstellen

Willkommen auf PSD-Tutorials.de

In unseren Foren vernetzt du dich mit anderen Personen, um dich rund um die Themen Fotografie, Grafik, Gestaltung, Bildbearbeitung und 3D auszutauschen. Außerdem schalten wir für dich regelmäßig kostenlose Inhalte frei. Liebe Grüße senden dir die PSD-Gründer Stefan und Matthias Petri aus Waren an der Müritz. Hier erfährst du mehr über uns.

Stefan und Matthias Petri von PSD-Tutorials.de

Nächster neuer Gratisinhalt

03
Stunden
:
:
25
Minuten
:
:
19
Sekunden

Neueste Themen & Antworten

Flatrate für Tutorials, Assets, Vorlagen

Statistik des Forums

Themen
174.476
Beiträge
2.577.966
Mitglieder
65.962
Neuestes Mitglied
seppeldeluxe
Oben