Antworten auf deine Fragen:
Neues Thema erstellen

Antworten zum Thema „!Hilfe... Problem beim animieren!“

DrNibbert

Noch nicht viel geschrieben

Hallo zusammen!

Ich hab ein ziemlich komisches Problem mit einer Animation die ich gemacht habe:

Ich will unser bandlogo (einen sendemasten) ein bisschen animieren, so das er im takt hüpft und so... is ja auch egal;)
Ich hab also ein Modell von dem Sendemasten gemacht, überall Joints und Anfasser eingebaut, alles funktioniert perfekt. (Wenn ich die anfasser bewege, bewegt sich das Modell genau so wie es soll)

Wenn ich jetzt aber diese Bewegungen in keyframes aufzeichnen will, werden plötzlich total andere Bewegungen erzeugt als ich eigentlich über die keyframes festgelegt hatte.

Um das besser zu verdeutlichen hab ich mal das Projekt hochgeladen:

Logo-test.c4d

Jetzt versucht mal den "Kopf"-Anfasser nach oben und unten zu drehen, und diese bewegung mit keyframes aufzunehmen...
Plötzlich dreht sich der kopf auch zur seite, obwohl man das garnicht wollte. Und wenn man sich nur eine der bewegungs-achsen im solo-modus anschaut, passieren ganz komische sachen....

Hilfe! :eek: was hab ich falsch gemacht?

Danke für jeden tipp!
 

fuxxx

Mod | 3D

AW: !Hilfe... Problem beim animieren!

lustige idee...
habs gerade mal probiert und bei mir funktioniert eig alles.
hab einfach keyframes für die position des Kopf nullobjekts gesetzt...

was passiert denn wenn du die keyframes setzt?
vlct wirds mit screenshot einfacher nachzuvollziehen...
 

DrNibbert

Noch nicht viel geschrieben

AW: !Hilfe... Problem beim animieren!

mit der position funktioniert es noch relativ gut, das problem ist dann das drehen des kopfes... also rotieren des Kopf-Nullobjekts... wenn ich den Kopf nach links oder rechts schaun lass geht alles, aber wenn ich ihn nach oben schauen lass fängt er an den kopf auch seitich zu neigen.
Und wenn man sich die F-Curves einzelln anschaut ( H P B getrennt) sieht man das da total unsinnige bewegungen aufgezeichnet werden (zum teil rotiert der kopf mehrmals um die eigene achse, wenn ich ihn für den keyframe nur ein kleines bisschen rotiert habe)... ein bug im programm kanns eigentlich kaum sein... ich hab schon versucht ein neues Null-Objekt zu erzeugen, es an die gleiche stelle zu setzen und damit das alte Kopf-Nullobjekt zu ersetzen, aber der fehler bleibt weiterhin...
 

hanco

ex

AW: !Hilfe... Problem beim animieren!

Und wie erstellst Du die Keyframes? Einfach auf den roten Knopf drücken oder erstellst Du selbige manuell im Attribute-Manager?
 

DrNibbert

Noch nicht viel geschrieben

AW: !Hilfe... Problem beim animieren!

powerslider auf das entsprechende bild, position einstellen, roter knopf, fertig ;)
 

hanco

ex

AW: !Hilfe... Problem beim animieren!

Und genau dort wird der Fehler liegen. Erstell die Keys manuell im Attribute-Manager. Da kannst Du direkt nur die Rotation für eine Achse keyen.

Der rote Knopf bewirkt, dass für alle Positions- und Rotationsachsen Keys aufgenommen werden. Nun ist dieser Key für die Seitwärtsbewegung jedes mal der gleiche, Cinema versucht das allerdings trotzdem zu animieren und es erfolgt eine Art überschwingen entlang dieser Keys.
Diese müssen dann also markiert werden und das Häckchen Abschneiden aktiviert werden - oder - was noch besser ist - diese Keys entstehen erst gar nicht.
 
Zuletzt bearbeitet:
Bilder bitte hier hochladen und danach über das Bild-Icon (Direktlink vorher kopieren) platzieren.
Antworten auf deine Fragen:
Neues Thema erstellen

Willkommen auf PSD-Tutorials.de

In unseren Foren vernetzt du dich mit anderen Personen, um dich rund um die Themen Fotografie, Grafik, Gestaltung, Bildbearbeitung und 3D auszutauschen. Außerdem schalten wir für dich regelmäßig kostenlose Inhalte frei. Liebe Grüße senden dir die PSD-Gründer Stefan und Matthias Petri aus Waren an der Müritz. Hier erfährst du mehr über uns.

Stefan und Matthias Petri von PSD-Tutorials.de

Nächster neuer Gratisinhalt

03
Stunden
:
:
25
Minuten
:
:
19
Sekunden

Neueste Themen & Antworten

Flatrate für Tutorials, Assets, Vorlagen

Statistik des Forums

Themen
174.478
Beiträge
2.577.990
Mitglieder
65.964
Neuestes Mitglied
Bina
Oben