Antworten auf deine Fragen:
Neues Thema erstellen

Antworten zum Thema „Problem mit Darstellung im IE“

gamax

Nicht mehr ganz neu hier

Hallo zusammen,

auf der nachfolgenden Seite habe ich einen Formmailer eingebaut, dieser wird im Firefox auch richtig und korrekt dargestellt, im IE aber kommt nichts, warum ?



Habe mit Include gearbeitet....

und zwei Formulare, einmal kontaktformular.php und kontaktformular_auswerten.php

Hier mal die Quelltexte : kontaktformular.php

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>Untitled Document</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>

<body>

<html>
<head>
<title>
<div align="center">
<body>
</div>
<div align="center"></div>
<table width="446" border="0" align="center" cellpadding="1" cellspacing="2">
<form action="kontaktformular-auswerten.php" method="post">
<tr>
<td>Name:</td>
<td><input name="Name" size="35" type="text"></td>
</tr>
<tr>
<td>eMail:</td>
<td><input name="Email" size="35" type="text"></td>
</tr>
<tr>
<td>Telefonnummer:</td>
<td><input name="Email" size="35" type="text"></td>
</tr>
<tr>
<td>Handy-Nummer:</td>
<td><input name="Email" size="35" type="text"></td>
</tr>
<tr>
<td>Betreff:</td>
<td><input name="Email" size="35" type="text"></td>
</tr>
<tr>
<td>Nachricht:</td>
<td><textarea cols="30" name="Nachricht" rows="10"></textarea></td>
</tr>
<tr>
<td>Wünsche Antwort:</td>
<td>Ja <input name="Antwort" checked type="radio" value="ja"> Nein <input name="Antwort" type="radio" value="nein"></td>
</tr>

<tr>
<td align="center" colspan="2"><input name="Send" type="submit" value="Abschicken"> <input name="Reset" type="reset" value="Löschen"></td>
</tr>
</form>
</table>
</body>
</html>
kontaktformular_auswerten.php

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>Untitled Document</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>

<body>

<html>
<head>
<title>Kontaktformular mit PHP</title>
</head>
<body>
<?php

$Empfaenger = "Patromis@t-online.de";

if($_REQUEST['Send'])
{
if(empty($_REQUEST['Name']) || empty($_REQUEST['Email']) || empty($_REQUEST['Nachricht']))
{
echo"Bitte gehen Sie <a href=\"javascript:history.back();\">zurück</a> und füllen Sie alle Felder aus!";
}
else
{
$Mailnachricht = "Sie haben folgende Nachricht erhalten: \n\n";
while(list($Formularfeld, $Wert)=each($_REQUEST))
{
if($Formularfeld!="Send")
{
$Mailnachricht .= $Formularfeld.": ".$Wert."\n";
}
}
$Mailnachricht .= "\nDatum/Zeit: ";
$Mailnachricht .= date("d.m.Y H:i:s");
$Mailbetreff = "Direktkontakt von www.asystcoach.de: ";
$Mailbetreff .= $_REQUEST['Betreff'];
mail($Empfaenger, $Mailbetreff, $Mailnachricht, "From: ".$_REQUEST['Email']);
echo"Vielen Dank für Ihre eMail!

<a href=\"http://www.asystcoach.de\">Hier gelangen Sie zurück zur asystCoach Seite.</a>";
}
}
else
{
echo"Ein Fehler ist aufgetreten. Bitte gehen Sie auf diese <a href=\"kontaktformular.php\">Seite</a>.";
}

?>
</body>
</html>


Ich hoffe Ihr könnt mir helfen und sagen wo der Fehler liegt !!!
Ist wirklich dringend !!![/b]
 

tymoe

graphicdrunkie

nimm mal das hier weg:

Code:
<html>
<head>
<title>
<div align="center">
<body>
</div>
<div align="center"></div>

das is sehr unnötig.
wenn du was includest, dann achte drauf dass du nur puren code includest ohne head und body dopplungen

grüße
ty!
 
A

ASQ

Guest

Jepp,,, das iss das prob,,,, IE nimmt nur 1x head... kommt ien 2ter , stoppt IE mit der interpretation

bzw... du hast im header auch shcon ein head,,,, du hast somit 3 mal ein Head auf einer seite

Code:
<HTML>
<HEAD>
<TITLE>Herzlich Willkommen bei asystCoach !!!</TITLE>
....
......
//-->
</script>
</HEAD>
...
....
...
<head>
<title>Untitled Document</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>

<body>

<html>
<head>
<title>
<div align="center">
...
.....
..
die schließeung vom dritten wird vermisst......
 
Z

ZeroniX

Guest

Als erstes solltest Du Dir merken alle mit IE zu testen., FF verfälscht ziemlich das Erscheinungsbild weil es einen andered cache nutzt.
 

Baci

Noch nicht viel geschrieben

ZeroniX schrieb:
Als erstes solltest Du Dir merken alle mit IE zu testen., FF verfälscht ziemlich das Erscheinungsbild weil es einen andered cache nutzt.
Ich geh genau andersrum vor ^^
Erst FF und dann an den IE anpassen 8)
 
Bilder bitte hier hochladen und danach über das Bild-Icon (Direktlink vorher kopieren) platzieren.
Antworten auf deine Fragen:
Neues Thema erstellen

Willkommen auf PSD-Tutorials.de

In unseren Foren vernetzt du dich mit anderen Personen, um dich rund um die Themen Fotografie, Grafik, Gestaltung, Bildbearbeitung und 3D auszutauschen. Außerdem schalten wir für dich regelmäßig kostenlose Inhalte frei. Liebe Grüße senden dir die PSD-Gründer Stefan und Matthias Petri aus Waren an der Müritz. Hier erfährst du mehr über uns.

Stefan und Matthias Petri von PSD-Tutorials.de

Nächster neuer Gratisinhalt

03
Stunden
:
:
25
Minuten
:
:
19
Sekunden

Neueste Themen & Antworten

Flatrate für Tutorials, Assets, Vorlagen

Statistik des Forums

Themen
174.479
Beiträge
2.577.999
Mitglieder
65.966
Neuestes Mitglied
Привет
Oben