Antworten auf deine Fragen:
Neues Thema erstellen

Scriptfehler aber wo?

aftern00n

Nicht mehr ganz neu hier

finde den fehler nicht warum das javascript :

Code:
<script language="javascript">
function over(imgname,imgsrc) {
document[imgname].src=imgsrc;
}
</script>

nicht funktioniert?

hier der komplette quelltext

Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>¨??°º?. sonYx.arTs .?º°??¨</title>
<script language="javascript">
function over(imgname,imgsrc) {
document[imgname].src=imgsrc;
}
</script>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<body bgcolor="#FFFFFF" background="images/back.gif">

<div align="center">
  <center>
<table id="Tabelle_01" width="702" border="0" cellpadding="0" cellspacing="0" style="border-collapse: collapse" bordercolor="#111111" height="91" bgcolor="#FFFFFF">
	<tr>
		<td>
			[img]images/spacer.gif[/img]</td>
		<td>
			[img]images/spacer.gif[/img]</td>
		<td>
			[img]images/spacer.gif[/img]</td>
		<td>
			[img]images/spacer.gif[/img]</td>
		<td>
			[img]images/spacer.gif[/img]</td>
		<td>
			[img]images/spacer.gif[/img]</td>
		<td>
			[img]images/spacer.gif[/img]</td>
		<td>
			[img]images/spacer.gif[/img]</td>
		<td>
			[img]images/spacer.gif[/img]</td>
	</tr>
	<tr>
		<td colspan="9" background="images/index_01_b.jpg" height="88">
			</td>
	</tr>
	<tr>
		<td>
			[img]images/index_02_b.jpg[/img]</td>
		<td>
			[img]images/index_03.jpg[/img]</td>
		<td>
			[img]images/index_04.jpg[/img]</td>
		<td>
			[img]images/index_05.jpg[/img]</td>
		<td>
			[img]images/index_06.jpg[/img]</td>
		<td colspan="2">
			[img]images/index_07.jpg[/img]</td>
		<td colspan="2" rowspan="2" background="images/index_08.jpg">
			</td>
	</tr>
	<tr>
		<td>
			<a href="home.html">
			[img]images/index_09.jpg[/img]</a></td>
		<td>
			<a href="about.html">
			[img]images/index_10.jpg[/img]</a></td>
		<td>
			<a href="work.html">
			[img]images/index_11.jpg[/img]</a></td>
		<td>
			<a href="websites.html">
			[img]images/index_12.jpg[/img]</a></td>
		<td>
			<a href="links.html">
			[img]images/index_13.jpg[/img]</a></td>
		<td colspan="2">
			<a href="guestbook.html">
			[img]images/index_14.jpg[/img]</a></td>
	</tr>
	<tr>
		<td colspan="9" height="166" background="images/index_15.jpg">
			</td>
	</tr>
	<tr>
		<td colspan="6" height="475" background="images/index_16.jpg" width="249">
			<p align="center">
			<IFRAME name=I1 
            marginWidth=1 marginHeight=1 
            src="content/home.html" 
            frameBorder=0 width="235" scrolling=yes height=459 
            bordercolor="000000"></IFRAME>
            </td>
		<td colspan="2" height="475" background="images/index_17.jpg">
			</td>
		<td height="475" background="images/index_18.jpg">
			<p align="center">
			<IFRAME name=I2 
            marginWidth=1 marginHeight=1 
            src="content/updates.html" 
            frameBorder=0 width="127" scrolling=yes height=459 
            bordercolor="000000"></IFRAME>
            </td>
	</tr>
</table>
  </center>
</div>

</body>
</html>
 

Antworten zum Thema „Scriptfehler aber wo?“

jezek01

Nicht mehr ganz neu hier

Ich habe von Javascript keine Ahnung, aber probiers mal hier


Hier kann man dir sicher helfen!

PS: erläutere dort dein Problem etwas genauer ;)
 

BlueThunder

Nicht mehr ganz neu hier

Hi!

Was genau an deinem falsch ist, kann ich dir auch nicht sagen :(

Mach doch mit Hilfe von CSS einen Hover.

Alternativ habe ich hier mal den Hovercode aus DW für dich...
Code:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"> 
<html> 
<head> 
<title>HoverBeispiel</title> <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"> 
<script language="JavaScript" type="text/JavaScript">  </script> 
</head> 
<body onLoad="MM_preloadImages('hover_bild.png')"> <a href="http://www.deinen_link.de" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swapImage('Hoverbeispiel','','hover_bild.png',1 )">
[img]bild_1.png[/img]</a> 
</body> 
</html>
(sieht etwas blöde aus. Schade, dass es keine HTML-Codeansicht gibt...)
Du musst nur beim "a href" und natürlich die Bildernamen anpassen.

MfG BT
 

Silent

Fotograf trifft Metal

fiel mir grad noch auf das du ein Iframe in einer tabelle benutzt , denke daran das eine Tabelle in einer Tabelle nicht in allen browsern geht --> D.h. das Iframe sollte möglichst keine Tabelle enthalten :)
 

Herr_D

offline

der fehler liegt in den bildern, besser in den bildnamen/bildbezeichnungen

du gibst allen bildern den gleichen namen, das funzt halt nicht ... du mußt jedem bild einen neuen namen geben ...

index_09.jpg



index_10.jpg



usw. usf.


besser weil übersichtlicher wäre wohl, wenn die bildnamen etwa den linknamen entsprechen ;-)



<td>
<a href="home.html">
index_09.jpg
</a></td>
<td>
<a href="about.html">
index_10.jpg
</a></td>
<td>


usw. usf....
 
Bilder bitte hier hochladen und danach über das Bild-Icon (Direktlink vorher kopieren) platzieren.
Antworten auf deine Fragen:
Neues Thema erstellen

Willkommen auf PSD-Tutorials.de

In unseren Foren vernetzt du dich mit anderen Personen, um dich rund um die Themen Fotografie, Grafik, Gestaltung, Bildbearbeitung und 3D auszutauschen. Außerdem schalten wir für dich regelmäßig kostenlose Inhalte frei. Liebe Grüße senden dir die PSD-Gründer Stefan und Matthias Petri aus Waren an der Müritz. Hier erfährst du mehr über uns.

Stefan und Matthias Petri von PSD-Tutorials.de

Nächster neuer Gratisinhalt

03
Stunden
:
:
25
Minuten
:
:
19
Sekunden

Neueste Themen & Antworten

Anzeige

Anzeige

Nächster neuer Gratisinhalt

03
Stunden
:
:
25
Minuten
:
:
19
Sekunden

Neueste Themen & Antworten

Anzeige

Anzeige

Flatrate für Tutorials, Assets, Vorlagen

Statistik des Forums

Themen
174.221
Beiträge
2.576.591
Mitglieder
65.481
Neuestes Mitglied
micfr

Zurzeit aktive Besucher

Keine Mitglieder online.
Oben